Weird problem

So I can connect to my server by specifying the IP address but I cannot connect to it using my domain name. The weird thing is that it was working a week ago then I had to restart my server and now it doesn’t work.

Here is my URL with my domain name (522 error): https://nssnotify.org/test-success

Here is my URL with the IP address: https://159.223.98.72:8443/test-success

Here are my DNS records:
A nssnotify.org 159.223.98.72
CNAME www nssnotify.org

I added the nameservers too. I have the ca and private key. It isn’t ufw related. What else can I look at?

No worries! Hopefully I’ll figure out what is wrong with my server eventually.

Your comments were moved because you have your own distinct issue and it is not fair to you or the originator of the other topic to hijack that topic. With your issues in their own topics you will both be able to receive individual attention and not muddle each others issues.

Okay, I won’t comment on other peoples posts anymore.

There is nothing wrong with commenting on other people’s posts when you are working on their topic. It’s just bad form to interject your own topic into someone else’s. How about we take a look at your question now?

You need to set the port in the URL with the domain name if you expect it to hit the same port on the origin server.

https://nssnotify.org/test-success connects to port 443 which is not listening on your server.

https://nssnotify.org:8443/test-success works as expected.

1 Like

Thank you! You definitely solved my problem. I fixed it. Thanks a lot!

2 Likes

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.