Weebly Issues

ssl

#1

It seems that Weebly does not want to play nice with Cloudflare, and I think that it has something to do with SSL, but I can’t be certain.

My site will not load when Cloudflare is enabled except for when I disable SSL. If I disable SSL on Weebly, then my site loads, but there is not SSL.

Has anyone successfully used Cloudflare with Weebly? If so, how did you setup SSL on both ends?

Thanks!


#2

Is your domain right now behind Cloudflare? Assuming that you dont need to hide the host behind Cloudflare (right?), can you post it?

You are not on their free plan, are you?


#3

I have Cloudflare paused right now. I’m not certain what you mean by “hide”.

Both Cloudflare and Weebly are paid subscriptions.


#4

By hide I meant hiding the origin host from the public. As this is is another service which should have their own protection against denial of service attacks I’d assume this is not the primary reason for you to use Cloudflare.

In that case, could you post the URL?


#5

No. Not hiding. www.centralvacuumservice.com


#6

Alright, the configuration looks alright. Which error do you exactly get? As your site redirects to HTTPS I could imagine a TLS redirection loop. When you enable Cloudflare, make sure your TLS mode under “Crypto” is set to “Full (strict)”.


#7

Thank. I did that, and the site loads now. I have Weebly SSL cert. on, and "Full (strict) set on CF.

What didn’t work was when I had Weebly SSL turned off, and also, when I used a paid SSL from CF.

I would like to use a paid SSL cert from CF because it will match my domain name, but I’m afraid to try that again, as my site would not load that way. Any suggestions in that regard?

Thanks!


#8

What was the TLS mode at Cloudflare at that point?

What do you mean by “match”? It does match your domain name, otherwise you’d get a TLS error. However it is a commonly shared certificate with other sites. However at this point it shouldnt matter which certificate you put in front of Cloudflare. The connection between your origin and Cloudfare is important and it seems this was where the error was.


#9

I think that tried “Flexible” and “Full”.

Just the way that the certificates are displayed.

This is what the free (included) cert looks like: ssl370484.cloudflaressl.com

I would prefer it be personalized with the domain name.


#10

If TLS was disable at the origin “Flexible” should have worked. “Full” not, as that requires TLS.

I understand, this is just the name of the certificate however, most people wont dig that deep :slight_smile: but if that is of concern you’d need to get a custom one. You can do this from the control panel too.


#11

Thanks again.

I did purchase a custom certificate but removed it because it also cased my site to not load.

If I had a custom cert. should I disable Weebly TLS?

Also, should I then disable CF “free” TLS? What should CF setting look like if I were to (re) purchase a custom TLS?

Thanks again!


#12

From Cloudflare or from a third party?

No, no, that is needed to have the connection between them and Cloudflare encrypted.

I am afraid I havent ordered a custom certificate from Cloudflare yet, so I cant say how the UI “changes” in that case. I would assume you wouldnt have to do too much, as the certificate would be automatically applied, but Cloudflare’s support can certainly help you, particularly as you are a paying customer and not one of those freeloaders :laughing:


#13

From CF

Got it!

Thanks!


#14

Then I would expect it to integrate seamlessly (just like shared one) but support should be able to tell you more.


#15

I have an uptime monitor on the site. It’s going down every 10 minutes with the error: (HTTP 525 - CloudFlare SSL Handshake).

It is going down for 4 minutes and 59 seconds at a time. So there must be some 5 minute timer on checking the SSL.

As this thread began, I think that Weebly doesn’t play nice with CF.


#16

Similar issues here, but since Weebly doesn’t offer SSL to the Deisgner Platform Pro Sites, we have no other choice but to figure this out.


#17

I’ve figured it out. The solution: Wordpress


#18

This topic was automatically closed after 14 days. New replies are no longer allowed.