Websockets not working with CloudFlare

Hi, I can’t get web sockets (servers) to work with cloudflare.
It works with cloudflare disabled, but here are the results (client logs) with cloudflare enabled:

using https://developers.cloudflare.com/fundamentals/get-started/network-ports:
ws = web socket
wss = web socket secure

http port (2082) + ws: hangs
http port + wss: Invalid TLS record type code: 72

https port (2087) + ws: HelpChat Paste
https port + wss: hangs

other port (25575) + ws: timed out
other port + wss: timed out

This is what my DNS record looks like: https://i.imgur.com/HXVmPwg.png

I don’t recall if Websockets is enabled by default, but have you checked your setting under the Network tab for your domain at dash.cloudflare.com?

1 Like

yes - it’s enabled.
It also says “Concurrent connection guidelines for your plan: low.” although I don’t know what it means :man_shrugging:

That just means there are limits to how much traffic you can have. They’re just not hard limits because you may have spikes and natural ebb and flow. These limits aren’t particularly low, but if nothing’s broken, there should be some connectivity.

1 Like

Hmm :thinking:

Atm the server is being hosted on my computer, so it’ll be offline the next couple hours
Anything I could do to try debugging when I come back?

Fixed - forgot to port forward the other ports (I only port forwarded and tested without cloudflare with 25575) :upside_down_face:

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.