Websocket Pages Can't Connect

Answer these questions to help the Community help you get started.

What is the domain name?

https://calinski.pw

Have you searched for an answer?
Yes

Please share your search results url:
Numerous Cloudflare

When you tested your domain using the [Cloudflare Diagnostic Center](https://www.cloudflare.com/diagnostic-center/), what were the results?
That link doesn’t work. It just takes me to the general help page, not a diagnostic center

Describe the issue you are having:
When I access my site using https:// the pages that use websockets report “not connected”. Other page displays fine. If I access via http:// they connect fine and operate correctly

What error message or number are you receiving?

None
What steps have you taken to resolve the issue?

  1. Searched the help using the keyword “websockets”. Nothing seem to help

Was the site working with SSL prior to adding it to Cloudflare?
I didn’t have SSL

What are the steps to reproduce the error:

  1. go to the site,
    2.enter password
  2. click on any link. every link on the index page uses websockets.

Have you tried from another browser and/or incognito mode?
I have only FireFox. On this windows8.1 computer the domain works fine without incognito mode because it returns http://calinski.pw. If I use incognito mode and type calinski.pw it returns https://calinski.pw. Then any page that uses websockets does not connect.
I have a tablet running windows 8.1. On it, typing calinski.pw in either mode takes me to the https:// secure page. Then only the page that has no websockets is the only one that functions correctly

Greetings,

Thank you for asking.

I’d suggest you to make a decision between if you want:

  1. Using HTTPS (secured way) with WSS
  2. Using HTTP (unsecured way) with WS

Either go with HTTP and WS and disable SSL for your domain → Flexible SSL/TLS would cause only issues.

Otherwise, the best scenario is to use Cloudflare Origin CA Certificate and Full (Strict) for SSL/TLS, therefore WSS in your web app.

To conclude:

  • Make sure there is a valid SSL certificate installed at your origin host/server (or use Cloudflare Origin CA Certificate)
  • Make sure the SSL/TLS option is set to “Full Strict SSL”
  • Make sure WebSockets feature is enabled at Cloudflare dashboard
  • Use WSS scheme

May I ask which port are you using and if the hostname (DNS record) is :orange: proxied? :thinking:

1 Like

I am sorry to say I don’t understand most of what you have said.
It will take me many hours to search the topics and understand what to do.
But I can’t work without access to my website for any length of time so I must remove it from Cloudflare.
J hope I can accomplish that by removing those two web addresses from my registrar.
Do I need to do anything else?

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.