Websocket: bad handshake after windows update

Please help!

i have updated my windows 10 to the very latest version and now i cannot connect using access/teams

i have cloudflared running as a service and i can see it in task manager and services.msc

i can authenticate and get my one time access code.

but when i run RDP on any client machine i get “Failed to connect to https://******* with error: websocket: bad handshake”

any help would be much appreciated

@lhoward can you confirm what version of Windows and Cloudflared you are using ?

Good morning

It was the upgrade to Windows 20H2, not sure what version of cloudflared.

The upgrade had removed the folder in System32


Thanks @lhoward sounds like there could have been some issue upgrading cloudflared.

Have you tried reinstalling cloudflared on the machine ? If not can you do that and then confirm if you still see the same issue?

I had to uninstall/install cloudflared from scratch, including the certificate, service etc.

Everything then started working again