Websites on JIO Network loading slow

Hi,

I tried everything, but JIO users have been facing slow and timeout issues for the last two months; I have other websites that are not using Cloudflare that are running fast.
Also, other networks are working fine, but only with the JIO networks. Websites are loading too slowly.

Did you report this to the folks at Reliance Jio?

yes they come to desktop and run some other websites done the speed test but everything is working fine and youtube is running on 4k video and other websites are working fine but only the websites hosted on cloudflares areslow.

Does Cloudflare team notice the issues here?

Members of the team are on this site every day. We’ve seen reports of traffic issues with Jio before, a :search: will reveal those. In this case, the issue appears to be related to the Jio network. Unfortunately, Cloudflare has limited control over individual ISP behaviors. You may need to report this issue to Jio network customer support. It’s also advisable to check if there are specific configurations needed for websites accessed over the Jio network that might be causing this issue. But, only the jio team will know for sure.

3 Likes

Hi,

I have looked up JIO support and they are saying that Cloudflare is limiting the jio users with speed as the websites that are not on Cloudflare are running too fast on JIO.

Please do something Cloudflare team this is really critical issue with your network as the websites does not load at all.Without cloudflare everything is loading fine.Cloudflare is blocking the network.

Hello,

I have used JIO and then used a VPN to access my websites and logged in to the wp-admin and then also updated posts of my Wordpress sites and it is working faster , Wow Cloudflare try to fix this thing please , the problem is not with jio the problem is with your cloudflare system.

I am using Reliance Jio Fiber Internet. This is happening too at my end if a site is being served by MRS PoP.

Cloudflare asking to complain about the pop to JIO Customer care , then this issue can be solved.

Same thing happening with me when accessing R2 storage files in my app with Jio network which on speed test have 400+ Mbps speeds and everything works fine but for some reason even 300-400kb file takes almost 30 seconds average time. I tested with Airtel network and Jio Fiber network, and it downloads the same file instantly. The problem seems to be with Jio with some selected servers.

Also, if you try to download any file from telegram you will get same result as I have described above.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.