Websites not working after adding sites and changing nameservers on Cloudflare

I have successfully added the domain (this domain is with GoDaddy, not NameCheap) to Cloudflare, however when i was adding the domain, it asked me to change the nameservers. I did change them and our main website is still working fine but our wholesale pages are down. The domains on the Wholesale pages are owned by GoDaddy. Does anyone know if the nameserver change (see photo) messed up where the subdomain is pointed towards? We need it to point it to Shopify wholesale. The wholesale pages won’t load so no one can sign up and no one can log in and place orders right now.

Can you share the name of the domain? It looks like you have zones that have moved between a few accounts. The name servers you shared are associated with an account that has two moved domains. But, knowing the domain will help us help you better. works fine, but these 2 websites (subdomains) are not working:

1 Like

It looks like you now have the proper name servers set.

nestednaturals is not proxied by Cloudflare, but works.
‘wholesale’ does not have a DNS entry. And that covers the two URLs you say aren’t working.


Thank you, I bumped your permissions so you won’t get that error again, sorry.

The reply from @sdayman is spot-on, you need to add a DNS record for the wholesale subdomain. Good info here, How to add subdomain to Cloudflare - #2 by domjh


would you kindly walk me through what i should fill in in order to add it? i tried it a few times but it didnt work

reason i’m asking is i have zero IT background and don’t quite understand the tutorial you sent me…

Your host should have the necessary information. Is the ‘wholesale’ subdomain hosted at the same place as the main site?

i’m finding the answer to your question. but in the mean time, i chose CNAME and tried putting “@” or “Wholesale” as the name, and “” as the target. both tries didnt work

do you think the problem will be solved if i change the nameservers back to what it used to be? in this case, change back to and

Those name servers don’t belong to the account you’re currently using, so anything you do in your current account won’t fix any problems.

If you want to try another shot at the CNAME, put ‘wholesale’ in for the name, and for the target.

just tried and it’s showing this, which it shouldn’t be, it should be a log in page of our website

So your main site is Shopify. Where’s the ‘wholesale’ site hosted?

our main site is but our subdomain (wholesale) should point directly to shopify wholesale

Did Shopify set up a ‘wholesale’ subdomain for you?

it was an add-on to shopify I believe and not it’s own website.

Ah, the instructions were right in front of my face. It says to Connect existing domain. But…did you? They should have some instructions on how to set up your wholesale site.

I did but it’s showing this

this is the tutorial and i’ve followed through it (top and bottom of the attached photo) but it’s still showing connection incomplete

Try setting it to :grey: DNS Only.