Websites have stopped working since switching to Cloudflare nameservers - please help

We have switched to using full Cloudflare (free package) for our domain names. However, the sites have stopped working and it’s been like this for a long time now (two days) so I’m sure the issue is not to do with DNS propagation.

The domain names are:


litmania.com

We are correctly using Cloudflare nameservers, as provided to us:
dahlia.ns.cloudflare.com
dane.ns.cloudflare.com

These are old websites and do not necessarily have https SSL compliance. Therefore, we have now set the SSL/TLS encryption mode from the original “Full” to “Flexible”. However, neither site works.

Please see screenshot of Cloudflare settings:

However, the domain names still don’t work.

Please see below the error message we see in our browser:

We’ve tried different browsers, computers, deleting the cache, disabling Cloudflare etc.

Please can someone kindly let us know what we can do to make these domain names work, as we are losing vital traffic?

Thank you.

That is insecure and you should install a certifiate on your server as you otherwise cannot have a secure site.

Thank you for the prompt response.

We are not bothered about having secure sites if we have to install certificates etc. How can we simply make these sites work please?

Then switch the encryption mode to Off and check if it works then.

We have tried that.

We still get the same error message, as per the screenshot above:

"This site can’t be reached

Check if there is a typo in www.1lit.com.

  • If spelling is correct, [try running Windows Network Diagnostics](javascript:diagnoseErrors()).

DNS_PROBE_FINISHED_NXDOMAIN"

We’ve deleted the cache etc.

Is there anything else we can try please?

tracert command in command line states:

“Unable to resolve target system name www.1lit.com.”

Thanks for your help.

Seems to be a DNS issue. Maybe try rebooting the router to update your local DNS resolver. Did you try that?

I’d still recommend installing an SSL certificate though. Particularly with Origin certificates that’s just a few clicks to have it issued and the server configuration shouldn’t be too difficult either. Then you’d be on Full strict and that’s the only secure mode.

The 1lit domain loads fine, except for Russia but I assume you imposed a block.

sitemeer.com/#www.1lit.com

I’ll try rebooting the router.

1Lit.com seems to be working now, since switching Cloudflare’s SSL setting to “off” as you advised. However litmania.com is not working - does it work for you when you visit the domain name please?

Is there anything we can do to get litmania.com working?

I have noted your worthwhile advice on installing certificates. I’ve checked at the webhost (Hostgator) and both these domain names have a Let’s Encrypt SSL Certificate installed. However, like I was saying in my post above, they are very old websites (I’m talking 20 years!) so they probably won’t be compliant with https.

litmania does not work because it redirects to its www record and that does not exist. You’d need to create it.

As long as you do not have logins or personalised areas there most certainly is no obligation to have SSL. If that site was done in a semi reasonable fashion switching even a 20 year old site to HTTPS should not be an issue, but if you prefer to keep it on HTTP that is certainly your choice, just make sure it is “Off” then as anything else will be an issue with HTTP only.

1 Like

I have noted that litmania.com does not have a CNAME for “www”. Therefore I’ve added that just now in case that has any impact.

Please see screenshot from Cloudflare’s settings for DNS management below.

Is it necessary to add this CNAME for “www” for every domain?

Thank you. It looks like we were posting here at the same time.

I have noted everything you have said and will try to get the SSL certificate working tomorrow (it’s midnight here in the UK).

Thanks a million for your fabulous help.

SSL is a must if you have parts where users submit data. If you don’t have it you put them at risk. If you don’t have any of that you do not necessarily need it, it really depends on your site.

The only thing, the proxy certificate is never enough, if you have SSL you need it on the server too.

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.