Websites Assets not updating, but content does?!

Hello there, this is my first community post.

I have published my personal website using Cloudflare pages.
The website is: https://tilmohr.com/
The source code is openly available under: https://github.com/CodingTil/personal-site
As technologies I am using Rust’s Yew.rs to build a WASM Website.
I have Cloudflare pages setup to build and publish my website (static) using the script build_release.sh which is stored within the reposity: https://github.com/CodingTil/personal-site/blob/main/build_release.sh.

Until a few hours ago this setup worked perfectly.
Now I am running into the following issue:
I have updated my websites content - more specifically the submodule https://github.com/CodingTil/fractal_rust which is integrated using an <iframe>, which is being rendered within https://tilmohr.com/fractal. Now, I have also updated the image that links the Homepage to this subpage, more specifically I originally had:


https://github.com/CodingTil/personal-site/blob/58b57ebdf5cf76ed096b431257619128e2ef25f4/src/images/projects/Fractal/file.webp
And now have:
![img2](https://raw.githubusercontent.com/CodingTil/personal-site/main/src/images/projects/Fractal/file.webp)
// can only put one image :frowning:
https://github.com/CodingTil/personal-site/blob/main/src/images/projects/Fractal/file.webp

As you can see, the filename remains the same.

When running the website locally, everything works perfectly fine - as expected, the new image is now shown on the Homepage.

However, on the published website, this is not the case - although the other change (the <iframe>) was updated! How can this be?

I do not use any build-cache within the Cloudflare Pages project, but have still tried to clear it and restart the pipeline - to no avail.

All help and suggestions are welcome!

That looks like the image is still in Cloudflare’s Edge Cache. Did you try purging your Cloudflare Cache?

That’s why you usually change the filename when you update static assets.

Yes, I have also tried the following just a few minutes ago:
Websites → tilmohr.com → Caching → Configuration → Purge Cache → Purge Everything

Unfortunately, that also didn’t help (or do I need to rebuild the Cloudflare Page now?)

Wait:

I was unaware of Browser Cache TTL. Is a smart technology though.

So, my browser still had the image cached, and therefore didn’t reload it.

After clearing the browsing data, now the image appears :smiley:

Thanks @Laudian for your assistance!

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.