Website works on Flexible SSL but not on Full

ssl
dns
godaddy

#1

Hello, I have a basic hosting on Goddady and I made a simple index.php to test if it was working, it was all okay, but then I changed the nameservers to Cloudflare and the website stopped working, even though it has the index.php it is taking me to the basic " Future home of something quite cool." page from Godaddy.
After messing around a bit, I found out that if I go to Crypto and change the SSL to Flexible, the website works and I can see the index.php I created, but on Full it doesn’t.
The big problem is that I need it to be on full, because on a different subdomain I use for another website it’ll not work on Flexible.
Anyone know a solution?


#2

This means that your origin server (your hosting account at Godaddy), is not configured to listen for HTTPS connections for your domain.

I’m not familiar with Godaddy’s dashboard, but there is probably a setting somewhere which allows you to set this up.


#3

Found the problem, had to set that up as you suggested, thank you!