Website won't update changes

Hello, where is the error, when my site can’t update changes on the front end? I also noticed that when I’m logged in, it’s showing changes updated correctly and immediately, but when I log out or check the website in the incognito window / different browser like mozzila / internet explorer it doesn’t show changes.

I tried:

Disable all plugins
Clear cache in WP / Browser
Tried different caching plugins
Purged cache in Cloudflare
Disabled Cloudflare for this site

My mate told me that Ezoic is root of the problem with their Cloudflare integration… could be this true ?? There is about 10 DNS Records from Ezoic all Proxied…

Nothing I mentioned above works… Could you check my site, please?

I also updated to the new theme 5 days ago, and it still showing the old theme (X Theme from Themeco) that I removed from the WP/themes… Anyway, the ads from the Ezoic are showing… that’s weird for me, thanks for the help.

If you disabled Cloudflare for the site and it’s still happening, then it’s not a problem with the Cloudflare cache. I do see you site is cached by Varnish, so that might be it. See if your host can track it down.

I’m beginner and my mate has access to the hosting but when I check where site is hosted, it is showing Cloudflare

And I don’t have Varnish plugin installed, where can you see that it’s cached by Varnish? Could Ad Network (Ezoic) cache the site ?

Varnish isn’t a plugin. It’s part of the web server itself. Your host isn’t Cloudflare, so you’ll have to find out where it’s hosted to find out how to clear that cache.

it’s hosted by CF… please how could you fix that for me? it’s soooo annoying, I can’t even change the theme, it’s like a old copy of my site

1 Like

Hi @amusicgearo, actually, as @sdayman mentioned, it’s not hosted by Cloudflare. Despite the information you see displayed, Cloudflare does not host sites, it looks like the site is active on Cloudflare, but we merely sit between site visitors and the actual hosting provider.

1 Like

I also thought that, thanks, I will ask mate he will know

1 Like

but isn’t there a way to access my root folder via filezilla client to check it please? Or don’t you know about reset of that settings so there will be initial settings but also will keep all the content there?

Your root folder where? There is no filesystem at Cloudflare to browse. Remember, you “Disabled Cloudflare for this site” and the problem persisted. This is not a Cloudflare issue.

This topic was automatically closed after 14 days. New replies are no longer allowed.