Website will not resolve

Hello. I am having trouble accessing my Website through Cloudflare. It seems that I have tracked it down to the DNS not resolving.

My registrar is DynDNS and I have change the DSN nameserve to the ones provided by Cloudflare.

I can type in the IP Address (before the Cloudflare activation) and get to the Webiste.
However, when I type in the website address it never connects and seems to just spin (in the browser for example)

Any ideas of what else to change or check?

thank you for your assistance.


It would be helpful if you could post the domain.


thanks for any help.


Looks like it properly resolves now, may have been DNS propagation

$ dig +short

Only issue I see now visiting the website is your Content-Security-Policy fails due to Rocket Loader, you should add or turn it off.

Also, you should turn on “Always use HTTPS” in the SSL/TLS app so that it redirects HTTP to HTTPS.

1 Like

Thanks for the help. Things are better now but still a couple of issues…
I think that the Rocketloader was causing my page not to display on my mobile device (iPhone - Safari). After turning it off now ok. Also I made the other change you mentioned.

However, on my mobile device, I use a couple of Synology (Server) apps - DS cam and DS file. Using my domain name it will not logon. But using the original IP Address direct it will logon with the Apps.

And The IP address you show above - This is not the actual IP address of my server. I assume that this is because Cloudflare has its own address which now resolves to this original address.

Thanks for any help and the quick responses.
Much Appreciated


Cloudflare works by putting a proxy in front of your server, so all traffic first hits CF, then it’s sent to your server, then your server responds and Cloudflare does all of its stuff like SSL, CDN, etc

Due to bandwidth/tech/etc limitations, users that aren’t on the Enterprise plan will only be able to proxy HTTP-based traffic. This means that if you try to access anything on a different port, or that traffic doesn’t use HTTP, then Cloudflare will be unable to proxy it and it’ll probably not work.

The only way to fix this is to either:

  1. change the DNS record from :orange: (DNS and proxy mode) to :grey: (DNS only mode), which will disable all CF protections, improvements, SSL, etc
  2. create a subdomain with the same IP, and have only that subdomain set to :grey:, which will allow your main domain to keep the benefits of CF.

If you just wanted to use a different Dynamic DNS host, 1 is a good option, but to use the other features the main domain does need to be :orange:.

Thanks. I am understanding this now.
So for a test I turned off the CF and just made it DNS. The 2 Synology Apps then worked. I turned CF back on and waited for a bit (tried right away but still work) since I assume that it will take a minute or two for CF To enable the Proxy. It then stopped working like I was thinking (message on app of Cant connect). These 2 mobile Apps use a different port.

But I also use Plex (a video and Music App) which also uses a different Port. It works ok… Curious.

Thanks for the quick and speedy help. Cloudfare is really cool! and Free! cant beat that.


Not all ports are proxied. And as @Judge mentioned, it’s only HTTP traffic.

A post was split to a new topic: New site not working

Thanks for all the help guys! This site is great and the community very helpful.


1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.