Website Went Down - Universal SSL Certificate Shows as Deleted - Nothing Fixed It

At first when I noticed the site was down, the SSL certificate showed as “initializing”

So I looked up what to do and tried:

  1. Un-proxying a record, waiting, re-proxying it
  2. Disabling Universal SSL Certificate, waiting, re-enabling it

The second step caused the Universal SSL to show as “deleted” - which unsurprisingly doesn’t help my website return to a functional state.

Yes, when you add a domain to Cloudflare, it may take a bit for the Universal SSL certificate to be issued.

When you disable Universal SSL, Cloudflare will delete the certificate. If you enable Universal SSL again later on, you have to wait a while for a new certificate to be issued.

I suggest you wait a few hours and check back.

1 Like

Thanks for your reply Albert - I transferred the domain a few months ago and only just now had the issue. I assume the issue arose in the 3 month renewal of the universal ssl.

When I disable the universal SSL, the SSL shows as blank.

When I re-enable it, it immediately shows the deleted one again (not initializing, not even nothing) and nothing changes from there. I’m only posting after working on this issue for a day or so. I’ll keep waiting I guess.

Thanks again for your reply! If any other ideas pop into your mind, let me know.

1 Like

You could try changing the CA:

I appreciate your help with this Albert! This is a bit over my head. I’m afraid if I can’t get it working - maybe by getting an SSL set up with my hosting (?) - I’ll have to transfer back out to Namecheap. I never had a problem with them.

No worries! I completely understand. Unfortunately, certificates sometimes get stuck for no clear reason. But this can usually be fixed by changing the CA, which will force Cloudflare to refresh the certificate. I wrote a short guide on how to do this.

You can get the zone ID from the overview page. The global API key can be found in your account preferences → authentication.

Thanks again Albert - that still looks beyond me and beyond what I’ll have time to figure out.

It’s my understanding that Cloudflare doesn’t let me choose my own nameservers on their free plan, and my host says they’ll need me to point to their nameservers in order to use the SSL they issued… meaning my easy option is going back to Namecheap.

Is my understanding about Cloudflare’s end on this right? Or is there a way to change nameservers on the free plan?

I just wanted to use Cloudflare as a registrar, nothing else at this point.

That is probably not necessary. Could you try just pausing Cloudflare? The button to do so is on the bottom right on the overview page.

That is correct. But even paid plans don’t let you change name servers when using Cloudflare Registrar. As far as I know, it is meant as a add-on service for people already using Cloudflare’s name servers.

EDIT: Your site loads fine over HTTPS for me now :slightly_smiling_face:

Yeah - I was able to get the website working by turning off all proxying. Fortunately my hosting helped me solve it. I don’t know what impact this has on Cloudflare’s services, but at least it got the website working.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.