Website URL is adding &i=1 while using Cloudflare and making it unable to use

Running opencart website on ifastnet webhosting provider. While using Cloudflare, backend administration panel url is adding &i=1 and making it unusable. when refreshed its incrementing to &i=2. Front end is working fine.

If I pause Cloudflare issue disappears.

Please help.

1 Like

What error are you getting?

Nothing. Just cant save the page.

Then what do you see?

same page appears without any result.

What page?

See, my actual url is
https://www.shaanstationery.com/admin
this is the login page

it redirects to https://www.shaanstationery.com/admin/?i=1

sometime it logs in, and some time it does not.

What will appear if log-in fails?

the same page appears and cant login.

Yeah, but does it say anything? (Like “Access denied, incorrect email or password!”)?

Nothing. displays the same page

Not only on this page. If I sometime login, internal pages are also facing the same issue.

This post was flagged by the community and is temporarily hidden.

Ok. I will check. But its incrementing from &i=1 to &i=2 then to &i=3

then it moves to https://www.google.com/cookies.html?backurl=http://www.shaanstationery.com/admin/index.php?route=common/login&i=3

404. That’s an error.

The requested URL /cookies.html?backurl=http://www.shaanstationery.com/admin/index.php?route=common/login&i=3 was not found on this server. That’s all we know.

404 Not Found ( RFC7231 )

Origin server was unable or unwilling to find the resource requested. This usually means the host server could not find the resource. To serve a more permanent version of this error one should use a 410 error code.

These errors typically occur when someone mistypes a URL on your site when there is a broken link from another page, when a page that previously existed is moved or removed, or there is an error when a search engine indexes your site. For a typical site, these errors account for approximately 3% of the total page views, but they’re often untracked by traditional analytics platforms like Google Analytics.

Website owners usually implement a custom page to be served when this error is generated.

Cloudflare does not generate 404s for customer websites, we only proxy the request from the origin server. When seeing a 404 for your Cloudflare powered site you should contact your hosting provider for help.

Yes. it displays only after 4th refresh i.e after &i=3.
Before that, main problem is with adding &i=1 to url.

What is this &i=1?

Strange.

I have visited your admin URL, I also got in the browser &=1.

It’s not incrementing at my end at least.
Value of the qurey string stays at 1 even after hitting refresh multiple times.

It’s not cached so far:

  • https://www.shaanstationery.com/admin/?i=1
Cache-Control: no-cache
CF-Cache-Status: DYNAMIC
cf-railgun: direct (waiting for pending WAN connection)

Redirect you to the path of dashboard - at least it should.

Possibly, issue as if Web browser default search is Google, and your web browser thinks entering each /something uses “search engine”, rather than the “webpage” you are using?

  • like a route is wrong, or rewrite location is a bit broken …

Seems like you did not accepted cookies for your Website first?

May I ask are you using some Web browser extension for Enhanced Privacy and possibly blocking cookies for your domain/Website (with www or without www?)

May I ask are you running some OpenCart module/exnension for “SEO URLs” or some security?

Have you tried to Purge the Cache at Cloudflare dashboard, just in case?

  • maybe something from your Web browser cache, try to clear your cache too …

Does it stil happen if you use some other Web browser or a Private Window?

EDIT/UPDATE: I see it shows redirect path to the HTTP URL (from HTTPS?), meaning something between HTTP<->HTTPS on your origin host (server) is misconfigured or you possibly have selected wrong SSL settings at the SSL/TLS tab of the Cloudflare dashboard for your domain name.

Before moving to Cloudflare, was your Website working over HTTPS connection and was the SSL enabled in OpenCart?

If so, did you had an valid SSL certificate installed at your origin host / server which covers both your naked (root) domain any any other needed sub-domain like www, mail, etc.?

May I ask what SSL option have you got selected under the SSL/TLS tab at Cloudflare dashboard for your domain ( Flexible, Full, Full Strict … )?

2 Likes

Hi, in my browser: https://www.shaanstationery.com/admin/?i=3 increase, please check:

  1. Any rule redirecting admin in your server and cloudflare.

  2. Url extension in opencart.

  3. For security reasons, change the name of the folder admin, and replace in config.php, the new url.

  4. The config.php file in the administration folder must comply with the correct syntax.

1 Like