Website Unreachable from Canada & Seattle When Cloudflare is enabled

This is a really weird issue that I never encountered before in Cloudflare. I did all the steps and tracing and found out that Cloudflare’s the cause of inaccessibility of my site isolated only to Canada users & some US states (such as Seattle).

My site is xtrahosting.net using the tool https://www.uptrends.com/tools/uptime testing North America, Vancouver & Seattle shows that my site is down and unreachable.

I learned this issue when one of my client from Canada told me that it takes forever to load the site and eventually fails. I checked but it was okay on my end (in Philippines, Asia).

Thought it was some issue with firewall on webserver, disabled it to no avail.

Set the cloudflare’s firewall to essentially off still not working.

Set a firewall rule to allow IP’s from CANADA to bypass the rule is getting hit but still not working

Seems to me like some network routing issue.

I paused cloudflare to my site (xtrahosting) and it worked and was reachable.

I have another site xpressmart(dot)tk hosted on the same server that is not on cloudflare and is also perfectly accessible.

Even GTMetrix canada server fails to connect to my site under Cloudflare.

Any clue & assistance possible on this one?

Attached two screenshots: With & Without Cloudflare

Best Regards,

Wilfred B

PS. Here’s the other screenshot since I’m limited to one image only.

Confirmed here, I can load the site through FRA, but on SEA it doesn’t load.

http://xtrahosting.net/ does return a 301 redirect to https://www.xtrahosting.net/ but from there I get a 522.

@xtrahostingnet Are you sure you don’t have any firewalls or other rate limiting that would limit Cloudflare’s ability to reach your server?

1 Like

The Italian checkpoint doesnt even make it to a TCP connection

sitemeer.com/#https://www.xtrahosting.net

My guess, there is some issue (routing?) with the two addresses assigned to that domain

@xtrahostingnet, open a support ticket at support.cloudflare.com/requests/new. Only support can look into this.

2 Likes

Thank you for the replies! I knew it was some issue with the routing. I created a support ticket now however it seems like cloudflare’s support is quite slow as of the moment due to the covid thing but I’ll see if they can do anything.

Best regards,

WIlfred B
Xtrahosting

Yes Dave. There were no firewalls and rate limiting feature that’s enabled that could cause this issue. I even tried adding page rules to disable security, peformance, apps but it still the issue would persist

If you dont have customised your account too much (and are not on a paid plan) you could move the domain to another Cloudflare account. That should to give you a different pair of IP addresses, which are likely to work.

I did this one already but it didn’t work unfortunately. My main account is wil*******@gmail.com and created a separate account for this particular domain. The nameservers changed but the issue is still there.

True, I do notice a change in nameservers but the IP addresses stayed the same. Not exactly what I would have expected, but wont solve the issue.

I am afraid only support can look into this and fix it. Can you post the ticket number, so @cloonan can push it maybe?

1 Like

Hi there Sandro,

Thanks. Here is the ticket number #1894810

Hoping they could look into this one.

Best regards,

Wilfred B

@cloonan

@xtrahostingnet, you did respond to any possible auto response, didnt you? Otherwise they might think the issue is fixed.

2 Likes

Hi there,

I just replied to the thread didn’t thought of that one thanks for the heads up.

Hoping cloonan could really expedite the resolution of the issue!

Best regards,

Wilfred B

Just an update. I transferred the server from Singapore to US, Chicago.

It did fix the issue so it must be really some routing issue with cloudflare from singapore.

Hope they can look into that one.

The transfer shouldnt have made a difference. Cloudflare assigned new IP addresses to your domain.

The previous IP address still is not reachable -> sitemeer.com/#104.18.60.32

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.