Website unreachable for half the world

For some bizarre reason, we are not reachable for half the globe: https://dnschecker.org/#A/6dsportsnutrition.com

It’s been like this for 12 hours now. Is there anything I can do?

Server itself (IP) is reachable.

Changing nameservers can take between 24 and 48 hours. Your DNS setup generally is correct and your domain does resolve. It is not proxied however (if that is of importance to you).

1 Like

Alright, I guess I’ll wait a bit longer. Hopefully it’ll get resolved without me interfering.
One question though: how does this suddenly happen?

Suddenly? When did you change nameservers? If you havent changed them recently, it is more likely that the website where you are checking has some issues.

We haven’t changed anything and our website was having trouble yesterday. Last night it worked for some people again, so I decided that if it was still having issues in the morning (today) I would switch from Dynadot DNS to Cloudflare. (which I did). That change was this morning. The weirdest thing is that if it were a server problem surely it wouldn’t resolve anywhere? Right now it works for me, but not for people in Germany or the UK for example.

Well, then you did make a change.

You are correct. However before that change, the website still wouldn’t load everywhere in the world (out of nowhere). I figured Dynadot DNS was acting up and that’s why I switched to Cloudflare (where this website will stay now, like all my other websites) Hopefully time will solve this. I keep refreshing the dnschecker website every few minutes.

I cant tell what the issue might have been before, but right now I’d attribute it to DNS propagation. You should simply wait for 48 hours without changing anything. If it still doesnt work at that point, one could have a look at what is not working.

Right now, however, your domain points to Cloudflare and Cloudflare properly resolves it.

Thank you for your advice, I will do just that.

You are right about Dynadot DNS issue. All my sites are down as of yesterday in half of the world. All of them are using Dynadot nameservers :confused:

The issue did indeed solve itself.
What have we learned? Don’t use Dynadot DNS, always use Cloudflare.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.