Website unreachable after connecting to Cloudflare DNS

To setup cloudflare DNS should be very straightforward.I followed the steps in the manual and Youtube instruction video. However, I can’t get it to work. After receiving the email from Cloudflare that the connection is now active, my website becomes unreachable. I thought it might be a SSL issue. When I changed from FULL to NONE, I get the ERR_TOO_MANY_REDIRECTS error. What could be the problem?

Set the SSL to Full strict. For more information on the error and resolution, check the Tutorial

1 Like

In addition to the excellent guide shared by @neiljay, it can be helpful to pause Cloudflare and make sure that your site is loading over HTTPS. Once the site is working correctly, you can then confidently re-enable Cloudflare with your SSL mode set to Full (Strict).

1 Like

I set it to FULL/strict to no avail. I reverted the domain back to my host’s name server because I need that website up.

I tried another site:

When I entered my site and it reviewed my DNS records, I noticed it had double records:

2 A, 2 AAAA, 2 CNAME, 2 MX, 1 SRV, 1 TXT

I removed one A, AAAA and CNAME record. For the CNAME record it found 2 ip adresses. I did a “ping domain name” and chose that ip address to keep.

Then I changed the NS servers at my host abnd followed the steps to finish:

Improve security - HTTPS rewrites: ON
It skipped Always use HTTPS: Off <=== !!! (it kept it OFF)
Optimize performance - Brotli: ON

After I recieved the email that my domain is now active on Cloudflare my website is not reachable anymore.

I saw that the SSL/TLS encryption mode was set to OFF. I changed it to FULL/strict to no avail.

Now it gives me the following error no matter what SSL setting:

Not Found

The requested URL was not found on this server.

Please help!

A post was merged into an existing topic: Requested URL not found

That only introduces unnecessary delays. Pausing Cloudflare is immediate. You do not currently have Cloudflare paused. You need to pause Cloudflare first and make sure that it stays paused until your site is working correctly over HTTPS.

The page being shown is being served by the origin server operating at the IP address that you have in your Cloudflare DNS.

Pause Cloudflare. Make sure your site is working correctly over HTTPS. Only then should you re-enable Cloudflare.

The site is now paused. How am I or anyone else suppose to troubleshoot? I followed the steps in the manual and then my site is not reachabe.

The only thing I found weird were the double DNS records, I have no idea now how to proceed.

Note: my site at my origin host has a SSL certificate.

Please provide an example of what you man by this. Proxied hostnames will always have at least 2 A and 2 AAAA records published.

It does and that is excellent. As you can see right now with Cloudflare paused, you origin server is returning a 404 page.* That is what needs to be fixed at that server. If your hosting provides support, it is a good time to talk with them.

Edit note:
* That statement was based on testing a different domain that you had in a comment that I moved to the other topic you created.

“Please provide an example of what you man by this. Proxied hostnames will always have at least 2 A and 2 AAAA records published.”

I thought Cloudflare was warning me that there were double entries. I guess I misunderstood.

“If your hosting provides support, it is a good time to talk with them.”

I’ll speak to them tomorrow. What am I suppose to ask them to do?

Btw: I can’t leave my website unreachable. i revert back now to my host’s name servers.

Or should I leave it like this, so that my host provider can troublehoot better?

Definitely don’t change your nameservers. Leave them at Cloudflare and paused so that you can properly fix things.

Please share a screenshot of what you see so that we can better understand what you are referencing.

How do I post a printscreen???

Above DNS records are the same on both domains, except the other domain has also double AAAA records.

The domain in your screenshot is not currently active in Cloudflare. I would leave it the way it is until you learn from your host how to correctly configure the DNS records.

I moved your one reply that contained the other domain into the other topic that you created for it because I was scrolling up to check your changes based on that domain which means some of my replies were based on that name. It is best to not mix separate issues in the same topic.

I didn’t make screenshots of the other domain when setting it up. Therefore I included these screenshots. They had the same DNS records anyway, except for AAAA.

Thanks for your help so far. I’ll speak to my hosting provider tomorrow. I’ll ask them if they can help me further. But what can they do? I changed the name servers to the Cloudflare name servers. What more should be done?

You will need to check with your host.

It may be that your host operates in a manner that cannot be used with Cloudflare.

Thanks. Now it makes more sense. I guess in that case I’ll have to migrate the whole domain to another host provider if I want to use Cloudflare’s CDN.

1 Like