Website took too long to respond. Help?

Answer these questions to help the Community help you get started.

What is the domain name?
blog.thetechverseguru .com

When you tested your domain, what were the results?
I am able to ping my domain, and I get 100%.

Describe the issue you are having:
Hello. So, here is the deal. I have been having issues with this entire Cloudflare thing for a while. I have tried researching it but there isn’t anyone I can find having this exact problem, I am also very new to self-hosting so there is a lot I probably don’t know. I am hosting a WordPress website physically next to me using docker, on docker I have a Ngnix proxy manager, and that goes through to Cloudflare. Porkbun .com hosts my domain.

I can ping it, and it says that no packets were lost. I also used a tool to see if my DNS was propergated full and it is. But it keeps saying whenever I try to access the website either from my system, a private browser, or a Tor browser, it states it took to long to respond. Now I have cleared the cache on both Cloudflare and on my browser, which is brave and still no use. I honestly have no idea what else to do. I have tried fully re-installing Nginx proxy manager and the WordPress website.I have used a tool called Let’s Debug to fix the issues I have had previously in the creation process, it tells me if like port 80 is down or if it can not access the server and it can.

Oh and SSL/TLS is set to Full.

If anyone can help let me know. Thank you in advance.

What error message or number are you receiving?
This site can not be reached.
blog.thetechverseguru .com took too long to respond.

Was the site working with SSL prior to adding it to Cloudflare?
I just got it this far, hasn’t been fully operation to the point where I can access it by domain name yet.

What are the steps to reproduce the error:

  1. Just load my website you will see.

Have you tried from another browser and/or incognito mode?
Yes, I have.

Set to “Full (strict)” to ensure you and your users’ data is secured end-to-end.

Your hostname is redirecting to itself on port 8181…
https://cf.sjr.org.uk/tools/check?c6728cc5d9ce4c678dcdcd82085d519e#connection-worker

Cloudflare’s proxy does not listen on port 8181, see…

You need to do one of…

  • Change the port to one supported by the proxy
  • Remove the port from the client side and configure Cloudflare to connect to your origin on port 8181 using origin rules…
    Available Origin Rules settings · Cloudflare Rules docs
  • Set the hostname to “DNS only”, but requests will go direct to your origin and not pass through Cloudflare for any protections or features to be applied

Debugging any SSL issues is difficult behind the proxy. It is best to pause Cloudflare, get SSL set up and working for direct requests to your origin server first, then when that’s working unpause Cloudflare.

2 Likes

Thank you very much for the help.

So I changed Cloudflare to “Full (strict)” SSL/TLS rather than full. I also changed the port from 8181 to 8080. It now works fully from my system and others.

Issue resolved.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.