Website suddenly stopped working through Cloudflare

Hi. Our website working over a year with no changes (Shop - Protect EMTB). DNS through cloudflare Proxy turned off. Suddenly it stops working, pages not loading images etc. However it works perfectly fine if I load it through a Proxy server site like eu2.proxysite.com - images load, can add items to basket and checkout etc.

Turned proxy on and made slight difference (some pictures load but not all but can’t add items to basket or checkout). Have turned proxy back off again. Tried purging case last resort not improvement. Currently in developer mode (no caching) just turned on.

Why would it not work natively with cloudflare but work perfectly fine through the public proxy? We have a .com and a .co.uk domain. Please help!?


The site isn’t proxied by Cloudflare, so the problem isn’t caused by Cloudflare. Check on your origin.

I’m not a web developer, but a quick look shows me that the sbjs tracking stuff in the Cookie is what’s breaking it.

With it in, you get a 404 for most images when I include all the headers my browser used…

curl -I https://protect-emtb.com/wp-content/uploads/2021/10/WHYTE-1-600x600.jpg \
-H 'Accept: text/html,application/xhtml+xml,application/xml;q=0.9,*/*;q=0.8' \
-H 'Accept-Encoding: gzip, deflate, br' \
-H 'Accept-Language: en-GB,en;q=0.9' \
-H 'Connection: keep-alive' \
-H 'Cookie: _ga_PC751H4WGJ=GS1.1.1705783033.1.1.1705783341.0.0.0; _ga=GA1.1.201422.1705783034; sbjs_current=typ%3Dreferral%7C%7C%7Csrc%3Dcommunity.cloudflare.com%7C%7C%7Cmdm%3Dreferral%7C%7C%7Ccmp%3D%28none%29%7C%7C%7Ccnt%3D%2F%7C%7C%7Ctrm%3D%28none%29%7C%7C%7Cid%3D%28none%29; sbjs_session=pgs%3D5%7C%7C%7Ccpg%3Dhttps%3A%2F%2Fprotect-emtb.com%2Fwp-content%2Fuploads%2F2021%2F10%2FWHYTE-1-600x600.jpg; sbjs_udata=vst%3D1%7C%7C%7Cuip%3D%28none%29%7C%7C%7Cuag%3DMozilla%2F5.0%20%28Macintosh%3B%20Intel%20Mac%20OS%20X%2010_15_7%29%20AppleWebKit%2F605.1.15%20%28KHTML%2C%20like%20Gecko%29%20Version%2F16.6%20Safari%2F605.1.15; sbjs_current_add=fd%3D2024-01-20%2020%3A37%3A13%7C%7C%7Cep%3Dhttps%3A%2F%2Fprotect-emtb.com%2Fshop%2F%7C%7C%7Crf%3Dhttps%3A%2F%2Fcommunity.cloudflare.com%2F; sbjs_first=typ%3Dreferral%7C%7C%7Csrc%3Dcommunity.cloudflare.com%7C%7C%7Cmdm%3Dreferral%7C%7C%7Ccmp%3D%28none%29%7C%7C%7Ccnt%3D%2F%7C%7C%7Ctrm%3D%28none%29%7C%7C%7Cid%3D%28none%29; sbjs_first_add=fd%3D2024-01-20%2020%3A37%3A13%7C%7C%7Cep%3Dhttps%3A%2F%2Fprotect-emtb.com%2Fshop%2F%7C%7C%7Crf%3Dhttps%3A%2F%2Fcommunity.cloudflare.com%2F; sbjs_migrations=1418474375998%3D1; cookielawinfo-checkbox-necessary=yes; cookielawinfo-checkbox-non-necessary=yes' \
-H 'Host: protect-emtb.com' \
-H 'Sec-Fetch-Dest: document' \
-H 'Sec-Fetch-Mode: navigate' \
-H 'Sec-Fetch-Site: none' \
-H 'User-Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_15_7) AppleWebKit/605.1.15 (KHTML, like Gecko) Version/16.6 Safari/605.1.15'
HTTP/2 404
x-powered-by: PHP/8.1.26
expires: Wed, 11 Jan 1984 05:00:00 GMT
cache-control: no-cache, must-revalidate, max-age=0
link: <https://protect-emtb.com/wp-json/>; rel="https://api.w.org/"
content-type: text/html; charset=UTF-8
date: Sat, 20 Jan 2024 20:58:35 GMT
server: Apache

Removed, keeping all the other headers, and get a 200 back…

curl -I https://protect-emtb.com/wp-content/uploads/2021/10/WHYTE-1-600x600.jpg \
-H 'Accept: text/html,application/xhtml+xml,application/xml;q=0.9,*/*;q=0.8' \
-H 'Accept-Encoding: gzip, deflate, br' \
-H 'Accept-Language: en-GB,en;q=0.9' \
-H 'Connection: keep-alive' \
-H 'Cookie: _ga_PC751H4WGJ=GS1.1.1705783033.1.1.1705783341.0.0.0; _ga=GA1.1.201422.1705783034;' \
-H 'Host: protect-emtb.com' \
-H 'Sec-Fetch-Dest: document' \
-H 'Sec-Fetch-Mode: navigate' \
-H 'Sec-Fetch-Site: none' \
-H 'User-Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_15_7) AppleWebKit/605.1.15 (KHTML, like Gecko) Version/16.6 Safari/605.1.15'
HTTP/2 200
last-modified: Mon, 04 Oct 2021 16:00:54 GMT
accept-ranges: bytes
content-length: 33093
content-type: image/jpeg
date: Sat, 20 Jan 2024 20:59:17 GMT
server: Apache

Googled and found this related to a recent Woo Commerce update…

Maybe that helps you track it down.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.