Website (subdomain) not showing unless logged in with WP or with extension

I made a subdomain (using CNAME “webshop” and in content “mydomain. com”) in Cloudflare. It points to the server of my provider.

Everything with some extension after the url (like webshop.mydomain.com/collections) shows without any problem, but the main page is just a static page. It doesn’t update and doesn’t show the page which it should show.

I suppose I did something wrong in the domain records. Also tried to reinstall this site, and checked database. I searched on the internet for a solution, but I couldn’t find a problem as specific as mine.

You’ll want to be sure the root domain has it’s own DNS record as well. That said, if the DNS is setup and you’re just not seeing the page content update, it may be that it’s just cached. Have you tried purging cache for the site?

  1. Login to Cloudflare and select the site with the resources to purge.
  2. Click the Caching app.
  3. In the Purge Cache pane, click Purge Everything.
    A warning dialog appears.
  4. If you agree, click Purge Everything.
1 Like

Thanks Chris.

Yes, I tried purging all cache, both Cloudflare and WP Rocket, and even after hours it’s still the same issue. The webpage is just completely stuck, here it is : webshop.waylanderwelding.com

Actually I copy pasted the site on the main domain, because I wanted the shop part do be the child domain. So I thought there must be something mixed up in the database too. But to be honest, I have no clue at all.

It may be that there is a cached resource on the origin. For example, if I make a request with a query string, I’m no longer served a 404:

https://webshop.waylanderwelding.com/?test

Is there additional cache you can clear on the origin server/site? I see the cache header sg-optimizer-cache-control in my response:

⭆ ~/ curl -IL https://webshop.waylanderwelding.com/
HTTP/2 200
date: Fri, 29 Jan 2021 20:28:21 GMT
content-type: text/html; charset=UTF-8
set-cookie: __cfduid=d4d5e3ac339cb0e333978cffd02d6ed531611952100; expires=Sun, 28-Feb-21 20:28:20 GMT; path=/; domain=.waylanderwelding.com; HttpOnly; SameSite=Lax
vary: Accept-Encoding
vary: Accept-Encoding
x-cache-enabled: True
cache-control: s-max-age=604800, s-maxage=604800, max-age=60
cache-control: max-age=0
sg-optimizer-cache-control: s-max-age=604800, s-maxage=604800, max-age=60
link: <https://webshop.waylanderwelding.com/wp-json/>; rel="https://api.w.org/", <https://webshop.waylanderwelding.com/wp-json/wp/v2/pages/2750>; rel="alternate"; type="application/json", <https://webshop.waylanderwelding.com/>; rel=shortlink
set-cookie: cookielawinfo-checkbox-necessary=yes; expires=Fri, 29-Jan-2021 21:28:21 GMT; Max-Age=3600; path=/
expires: Fri, 29 Jan 2021 20:28:20 GMT
x-httpd: 1
host-header: 8441280b0c35cbc1147f8ba998a563a7
x-proxy-cache-info: DT:1
set-cookie: cookielawinfo-checkbox-non-necessary=yes; expires=Fri, 29-Jan-2021 21:28:21 GMT; Max-Age=3600; path=/
cf-cache-status: DYNAMIC
cf-request-id: 07f16e2ba000002f498f269000000001
expect-ct: max-age=604800, report-uri="https://report-uri.cloudflare.com/cdn-cgi/beacon/expect-ct"
report-to: {"max_age":604800,"endpoints":[{"url":"https:\/\/a.nel.cloudflare.com\/report?s=EnPb1oz8sizVdwdm630SzhVbBX9DZBZ%2FHW88VZo8cTUEWrwjzRapG8VrFypP1sZso%2Bg4TGDZBOihMQisLHVc6w8LWaCF%2FW3eo2S3sd2srKpIGJ7F0MjJgGPWI8Q9"}],"group":"cf-nel"}
nel: {"report_to":"cf-nel","max_age":604800}
server: cloudflare
cf-ray: 6195b2f2980a2f49-DFW
1 Like

I did clear cache from Siteground (thats SG Optimizer) and the support from Siteground also cleared that cache. Is it possible to have something stuck in cache for +12 hours?

I also turned off all plugins, so also all cache plugins, but not sure if that really works.

The response I got in my test indicates that Cloudflare was not caching the page actually:

cf-cache-status: DYNAMIC

From Understanding Cloudflare's CDN – Cloudflare Help Center

DYNAMIC - Cloudflare does not consider the asset eligible to cache and your Cloudflare settings do not explicitly instruct Cloudflare to cache the asset. Instead, the asset was requested from the origin web server. Use Page Rules to implement custom caching options.

The max-age=604800 shows the origin was caching for a week though which is where those responses were coming from in this case.

A good guide on the SG Optimizer cache headers can be found at Cloudflare Full Page Caching in SG Optimizer.

Thanks for your input Chris. I must say, I got impatient and decided to ditch the subdomain as the main link for the webshop. So I created /webshop now and actually with that everything is solved.

Thanks again for your help, really appreciate it!

1 Like

This topic was automatically closed after 31 days. New replies are no longer allowed.