Website still shows unsecure after activated

Good Day Everyone

I activated the website http://lameezbenjamin.com on cloudflare, a few days later I received an e-mail showing the service has been activate however when visiting the website it still shows unsecured

HTTPS works. You just need to turn on “Always Use HTTPS” in the SSL/TLS “Edge Certificates” section.

1 Like

Thank you! Enjoy the rest of your day.

1 Like