Website still shows as Unsecured SSL

My website still shows as unsecured website (SSL). I’ve already cleared my cache and tried on a bunch of different browsers. The only that seems to say that it is secured is Opera Browser.

Any help would be much appreciated as I don’t know what else to do!

Have you checked out the troubleshooting guide?

Can you share the domain so others can check?


Thank you for your reply. I’ve just finished going through the steps and still not fully fixed! Going through the list, replies as follows:

1. Check that the DNS record is set to :orange: -

CHECKED. All are orange and on

2. Check that HTTPS doesn’t work

I’m not sure how you can fully tell whether it loads with the Cloudflare certificate but it shows a padlock sign with a ! on it. I did go ahead and enable ‘Always use HTTPS’ as instructed and cleared the cache and cookies again but still no change.

3. Do you see a certificate from your server?

I removed the previous SSL certificate from my previous hosting company because it didn’t work at all so there shouldn’t be any others on the server (although the site is hosted by a 3rd party who gave me directions to redirect and point to their IP via the ‘A’ Record)

4. Is it a mixed content issue?

This could be a possibility in that I do see a triangle / not fully secure message, as the main website is hosted elsewhere so not sure if there are any provisions around this?

5. Has your Cloudflare Certificate Provisioned?

It shows status as ‘Active’

It’s precisely the step @anon9246926 mentioned. You do not have a valid server certificate and your host needs to fix that.

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.