Website still not secure

Hi all,

I have created a Cloudflare account and changed the name servers acciordingly. It seems that the SSL certificate is working, but I still don´t receive the “Website is secure” lock. I have set up the options “Always use HTTPS” and “Automatic HTTPS rewrites”. I have also checked in the code but it seems all pictures and files are in a “https” format.

Could you please help me? My website is https://www.chrissawo.com

Thank you!

Kind regards,
Chris

Does your server IP address end in 192? If so, the fundamental issue is that your server itself is not secure, as it does not have a certificate to begin with.

Thank you, Sandro. Yes, the server IP ends with 192. I don´t have a SSL certificate on my server (I need to pay for that on my web host), that´s why I chose Cloudflare and took the option “flexible”. Is it not possible to receive a green secure look this way? I only have a private page without any shop functions.

Flexible should not be chosen I am afraid. Get a proper certificate on your server and switch to Full strict, otherwise your site cant be secure.

I have now installed a SSL certificate on my server and changed to “Full strict”, but I still don´t see the green secure lock: https://www.chrissawo.com.

Is there a further issue?

There are mixed content issues.

You can see the list of resources that cause the problem in the console of the browser.

How do I fix the SSL Mixed Content Error Message?

1 Like