Website SSL Not Working

Hello Everyone,
I really don’t understand why isn’t my SSL lock showing in the browser? When I visit my website It shows your connection to this site not secure. But When I access my admin panel it works there to show the connection is secure.

I’ve tried all these steps:

  1. Installed Really Simple SSL Plugin (uninstalled now)
  2. Cloudflare Flexible Plugin
  3. Cloudflare Plugin
  4. Always Use HTTPS in Cloudflare.

My Website: digitalinformix.com

Please help. Thanks in advance.

Hi @DigitalInformix,

That looks like mixed content:

Mixed content errors mean that your website is being loaded over HTTPS but some of the resources are being loaded over HTTP. To fix this you will need to edit your source code and change all resources to load over a relative path, or directly over HTTPS.

For example, if you load your images with a full URL:

<img src="http://example.com/image.jpg" />

You would want to change this to:

<img src="//example.com/image.jpg" />

By removing the http:, the browser will use whichever protocol the visitor is already using. An alternative option would be to enable the Automatic HTTPS Rewrites feature that can potentially fix these errors for you automatically. Do be aware that resources loaded by JavaScript or CSS will not be automatically rewritten and mixed content warnings will still appear.

See this Community Tip for further details

Also, reference Flexible SSL - you should be aware of Why flexible SSL mode is not the best choice

1 Like

Hi!
Thank you for your quick response. But I am not using this kind of link on my website anywhere. Means When I link any thing I simply link as dgitalinformix.com without any https:// or http:// . And I am using Wordpress website. Please guide me.

If you have a look at the #CommunityTip I linked to, there is a point on WordPress sites there.

1 Like

Yes. It working now Thanks.

1 Like

This topic was automatically closed after 30 days. New replies are no longer allowed.