Website SSL issue

ssl

#1

I have a website whatsappmp4.com which I set it up on cloudflare 3 days ago.
The website works fine on http but not https
I have added the redirect rule in my hosting .htaccess file.
I already have similar websites working fine but this particular website is not working.
The DNS shows my A record and www CNAME is behind cloudflare.
I have been trying to purge everything and still I’m not able to get it working.


#2

Your webserver is not properly configured to serve HTTPS. You can either set your TLS mode in Cloudflare to “Flexible” (but this will mean the encryption between Cloudflare and your server will be still unencrypted) or get your hoster to configure your domain/server properly.


#3

As I said earlier, I have similar websites on the same shared hosting. All are working fine. This issue is with this particular website. Changing it to flexible does not help. It gives the same error page.


#4

Just because other sites are working fine does not mean this one has to. You need to ask your host and get him to fix this. If you get the same on Flexible it would seem your domain is not set up at all.


#5

Using the flexible option and purging cache it gives the following error
ERR_TOO_MANY_REDIRECTS

What do you mean by “your domain is not set up at all”
Can you please elaborate.
Thank You.


#6

Well, considering your get the same error page it would mean your webserver cant find any association with your domain, hence it is not set up at all on your webserver. I initially thought it was an HTTPS issue, hence I suggested “Flexible” as temporary workaround until HTTPS is fixed on your server. If that is not the case your host would need to make sure your domain is properly set up.