Website showing as "Not Secure" in Chrome

G’day!

image

To provide some context, the DNS hosting was transferred to Cloudflare before the website was created. It looks like the issue is isolated to Chrome only, I checked using Safari and Firefox and I don’t get the same issue.

Notes:

  1. I’m not a web dev but I’m familiar with DNS so please bear with me.
  2. The domain uses the universal SSL from Cloudflare.
  3. The encryption mode is “Full” but if I change it to “Full (strict)” I get an Invalid SSL certificate (error 526).

Let me know if you need additional information to troubleshoot this further.

TYIA!

Your site contains a link to http://best-life-tips.com/wp-content/uploads/2024/02/Seth-Media-Light-Website.mp4 so is mixed HTTP and HTTPS content when accessed over HTTPS. Change this link on your site to https:// (or enable “Automatic HTTPS rewrites” in Cloudflare).

Use only “Full (strict)” to ensure your site is fully secured. Fix the SSL certificate on your server to make sure it is valid (not expired, not self-signed, from a trusted CA, etc) so you don’t get the 526 error.

2 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.