Website returning 500 error but it works fine when accessed without Cloudflare

Hello everyone,

My website suddenly started returning 500 error responses. Instead of the Cloudflare html page that says that the origin is returning a 500 error, I just get a blank page and looking at the http response it shows a 500 error response. If I disable Cloudflare for the domain and access the website directly, the website works correctly. This looks like an issue with the Cloudflare server. I have contacted Cloudflare support but they are slow to get back to me. Hopefully someone here can give me some tips.

Thank you very much!

A 500 is typically returned by your server, so you should check your server logs for that.

But what’s the domain? Censoring that when asking for help is not exactly the best idea :wink:

The logs are clean. Like I said earlier, the website works fine when I access it directly without the Cloudflare proxy.

Please check the website in my profile. Thank you.

Are your records currently proxied?

Yes, the DNS records are currently proxied through Cloudflare.

You have rather peculiar proxy addresses. Is this a standard setup or have you signed up with some Cloudflare partner or was your domain possibly earlier on such a setup?

It is a standard setup. It is a pro website running with Argo. I have tried disabling Argo, disabling the web firewall but the problem remains. I have been with Cloudflare for over 3 years, this is the first time something like this happens.

Have you tried whether disabling Argo makes a difference? Cloudflare rolled out a new version and I could imagine there could be some glitch.

Yes, I tried with Argo disabled and the problem is the same. I have disabled Argo again for you to test.

You still have a rather odd address pair, so I am afraid I would rather not comment on it as it is not clear why your domain is configured the way it is. Maybe other @MVP have an idea.

Thank you very much for looking into this.

What’s the domain?

Please check my profile

Did you make any changes to origin server configuration when you enabled CF Argo smart routing? Note Argo Smart Routing is not same as Argo Tunnels which is now called Tunnels.

  1. Are you only running Argo or also running Argo Tunnels with Cloudflared service on origin server ? If you have Argo Tunnel and Cloudflared too, then disabling Argo from CF dashboard won’t be enough, you’d still have Argo Tunnel running via Cloudflared service which needs turning off and having CF DNS updated to point away from Tunnel created address back to your origin IP.

  2. If you have Cloudflared server running for Argo Tunnels too, then disabling Firewall would prevent Cloudflared to communicate with CF edge servers via port 7844 as outlined at https://developers.cloudflare.com/cloudflare-one/faq/cloudflare-tunnels-faq.

  3. If you setup Argo Tunnels but didn’t configure your origin server firewall to allow 7844 port connections to listed CF IPs at https://developers.cloudflare.com/cloudflare-one/faq/cloudflare-tunnels-faq#what-are-the-ports-and-ips-used-by-cloudflared then that would also cause problems with it functioning assuming you have Argo Tunnels and not Argo smart routing.

I am disabling the Cloudflare proxy until the problems gets fixed by Cloudflare. So it will not be possible to diagnose the problem directly on the domain.

You seem to have a security issue

That’s because I am no longer proxying through Cloudflare. I am setting up my SSL certificates as we speak.