Website resolving to old IP webserver

Quite simply, a website address is still resolving to an old IP/web server, displaying the content of an old website.
The nameservers for the zone in my account are the zone shows as live, so I know that my DNS is the ultimate truth.
However, the only record I have points to the new website server.

Usually, I’d experience a similar problem due to ISP caching, but it’s occuring with almost all ISP’s i’ve tested (never known it to go on this long).
I even primarily use CloudFlare’s DNS resolver!

Because even the resolved records are proxied (we load balance the web server itself), I can only ever see CloudFlare’s IP address.

root domain:
straightrange.co.uk

website hostname:
www.straightrange.co.uk

Who is experiencing this, just you or are all users getting send to the old IPs?

I have done a quick check:

  1. DNS Checker: straightrange.co.uk
  2. DNS Checker: www.straightrange.co.uk

Both URLs are using Cloudflares IPs and therefore should respect the IP you pointed them in your Dashboard. If in the Dashboard are still old IPs then ofc your domain will be directed to the old IPs.

2 Likes

“should respect the IP you pointed them in your Dashboard”
Indeed it should, but it simply isn’t and it makes no sense. The DNS record for the website (www.) is pointing to our webserver^

^it’s actually aCNAME pointing to a loadbalancing record on another one of my domains, but that’s irrelevant. DNS checker will unfortunately return CloudFlare’s IP range even if it was stuck showing the previous record values, because the previous DNS provider also used CloudFlare with proxied records :frowning:

What I can tell you is that the DNS in my account is 100% active and controlling everything.
I’ve tried deleting records, witnessing the temporary downtime, then re-adding them and the website comes back up - but it’s the old website and therefore must be resolving to the previous web provider.

I’ve tested using multiple ISPs and even online proxies and VPN’s etc. Still points to the old webserver.
The previous provider is seemingly still hosting their website files on that server, which I’m kind of glad about, otherwise my customer would have no website showing at all.

Is there some sort of internal CloudFlare cache? …maybe considering that the same DNS record (although with different server/content values) existed within CloudFlares within two separate accounts?
I’m not referring to edge cache here, that has been disabled for now

This post was flagged by the community and is temporarily hidden.

Sort of…if it’s a :orange: DNS Record, which it sounds like you’re using, there are situations where a previous integration still has control over your :orange: DNS.

But if you toggle it to :grey: DNS Only, it should go to the origin you specify.

1 Like

I have a proxied record on the root domain, because I have a page rule which redirects the root to www.
I’ve kept that one on because it seems to be working.

I’ll now change the website hostname (www. record) to DNS only, wait until it works, then switch it back.

1 Like

It’s been 3 days since this issue started, and 24hours with a DNS only record.
I never experienced anything like this before.

There must be something inherent that is wrong here?

also, I would suggest that the possibilty of a previous integration having control over my DNS is a bit worrying.

How did this go?

Sorry I posted just before you did, you may have missed it :stuck_out_tongue:

24 hours later, there is still no resolve.

According to DNS Checker, as recommended by @M4rt1n , those are still resolving to Cloudflare IP addresses. Are you sure those DNS Entries are set to :grey: DNS Only?

Can you confirm that the two Cloudflare name servers at the bottom of that DNS page are Alla and Anirban?

1 Like

That’s exactly the issue. Somehow DNS resolvers are going to cloudflare (because of the nameservers) but CloudFlare is actually dishing out the prevous DNS providers records (which no doubt are/were proxied)

I see two things now:

  1. It’s a CNAME, and Cloudflare will “flatten” the CNAME at root.
  2. The target is on Cloudflare, which brings us back to this:

Because your domain points to a :orange: DNS Record, that old host is intercepting those requests. You’d have to ask that old host to completely remove your domain from their, and Cloudflare’s system.

1 Like

The previous DNS provider (who was also the website provider) recently deleted the website, so it went to a 404.
I’ve asked them to delete their CloudFlare zone.

In the meantime, I’ve change the DNS to records which are not proxied (and also don’t resolve to a proxied location - which was my mistake before because they were CNAMES).
Anyway, it seems to have honoured those records and it’s now pointing to the new resource.

But any attempt to proxy a record doesn’t change this at all!
I’m awaiting confirmation from the previous DNS provider that they’ve deleted the zone.

If they have, and it’s still an issue - I’m not sure how to escalate this :confused:

1 Like

Incidentally, this has occurred again with a different domain.

Same situation in which the previous DNS provider also uses CloudFlare proxied services.
We have done this for a long time (with both the previous provider and myself using proxied services) and this hasn’t been an issue until recently, hence I created this thread.

We need to get to the bottom of why CloudFlare is “caching” (if you can call it that) information between two completely different cloudflare accounts.
If the NameServers have been changed, that should be honoured! I would consider this a security flaw.

It’s not necessarily caching. It’s that your previous agreement with the other host has allowed them to capture your domain’s traffic when it goes through Cloudflare. I’m definitely not a fan of this arrangement, as it takes some extra effort to get it back if that other host isn’t freely willing to release the domain, or just doesn’t know how.

The previous DNS host is AutoTrader
The domain is for a car dealership customer
We (my company) are the new DNS host.

Each CloudFlare account is given different NameServers if the domain is the same, so why on eart isn’t CloudFlare honouring the NameServer change as they would for non-proxied services.

I agree; it shouldn’t even be an “arrangement” at all. AutoTrader’s zone record should be null and void.
How do I get the attention of CloudFlare staff to resolve this because it’s going to be a constant problem for me…

We’ve brought this up a few times now. There currently isn’t a way to get back control from a previous SSL for SaaS / Custom Hostnames setup without the old provider deleting it or, if they won’t, Cloudflare Support verifying the domain and manually removing it.

If you are on a paid plan with Cloudflare, feel free to use your access to their support channels to ask about this, unfortulately if you’re not then you’re a bit stuck here on the community.

1 Like

I’d recommend that if you’re using Cloudflare as a critical business component, that you use a Paid Plan so you can get direct support for issues such as this. Just as Auto Trader used a paid setup to support their client, so should any host that’s using Cloudflare for client sites.

1 Like