Website performance SAME with Cloudflare

To increase the performance score of my website https://patrickmovingstorage.com/ on pagespeed.web.dev specially for mobile, I installed WP Rocket and Cloudflare Free Plan. This did increase the score for mobile from 53 to 79 and for desktop  from 86 to 94. As I was aiming for a score of 95 for mobile, I purchased the Cloudflare Pro plan and did all the settings. However, there is no increase in mobile score. In fact it has fallen by 1 point as it is now 78. See here https://pagespeed.web.dev/analysis/https-patrickmovingstorage-com/gi6bxelkfh?form_factor=mobile
Desktop has increased by 2 points to 96.
Why is Cloudflare not increasing mobile performance score? Am I doing something wrong? Any guidance for increasing mobile score to 90 + will be highly appreciated.

I have not set up any configuration rules. Should I set them up? I am not sure if I need them as I have a small website.

Thanks.

Related to the WP Rocket, may I ask if you’ve followed the instructions for compatibility setup, just in case, while using it with Cloudflare from the article below? :thinking:

May I ask if you’ve configured and enabled the options like Argo Tiered Cache, Polish, Mirage, HTTP/2, HTTP/3, 0-RTT, Brotli …? :thinking:

I could suggest you to take a look at the article below which include useful and helpful information to double-check:

Domain: patrickmovingstorage.com
Thanks for the guidance. However, I have done all that is given in WP Rocket Knowledge base. Also I have done all the recommended image, content, protocol optimization settings in Cloudflare.
Polish enabled with Lossless and WebP checked
Mirage enabled
|HTTP/2|Enabled|
|HTTP/3 (with QUIC) |Enabled|
|HTTP/2 to Origin|Enabled|
|Enhanced HTTP/2 Prioritization|Enabled|
|Brotli|Enabled|
|0-RTT Connection Resumption|Enabled|
|Always use HTTPs|Enabled|
|TLS 1.3||Enabled|
Cloudflare Fonts |Enabled|
Early Hints |Enabled|
Rocket Loader |Disabled| Earlier it was enabled. Enabling or disabling has not effect on mobile score
Auto Minify - JavaScript, CSS, HTML |All 3 checked|
APO for WP enabled
Automatic Signed Exchanges (SXGs) |Enabled|
AMP Real URL |Enabled|
Unfortunately, the mobile performance score has fallen from 79 to 74.
FCP 2.0s
LCP 5.0s
Speed Index 4.6
I am testing on pagespeed.web.dev
I would appreciate any help in improving mobile performance score to above 90.
Thanks.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.