Website page speed is only slow in my local country

Hi all,

Been experiencing issues with slow loading on both frontend and backend of wordpress. it loads so slow that i cant even publish articles. This only happens with 2 of my sites under the same Cloudflare. Programmers in India and server guys in US are not having any issues at all so they cant diagnose the problem for me. I tried clearing browser cache, disabled all plugins, used different network and computers. They all dont work. site still loads really slow. I am located in Singapore btw.

I did a test with webpagetest.org targeting region: singapore and realised it takes 40s to fully load my homepage.

Heres a sceenshot of the test did for singapore:

I have one more screenshot the test with US as target region but my account only allows 1 image upload so i cant upload it. But it is showing 4secs time taken to load while Singapore is 40secs! Really dont know what is going on.

And worse of all is that support doesn’t allow me to open a ticket. it is showing me error 1000 when I try to send out a ticket. Is it because i am on a free account?

Did anyone encounter the same issue? any help or advice will be greatly appreciated.

Thanks in advance.

Are you using Page Rules especially cache everything? This guide can help - https://support.cloudflare.com/hc/en-us/articles/200172256-How-do-I-cache-static-HTML-

Looks to me like the typical case of a poorly configured Wordpress setup.

I cant reproduce a 40 second page load, it takes about five seconds from Singapore (http://webpagetest.org/result/190730_FE_043672c6e57fbaddb0b75938e89096a1/), respectively threeish globally for TTFB -> http://sitemeer.com/#https://exopetguides.com/

The Webpagetest actually goes via Cloudflare’s Singapore PoP. I presume you server is in North America, right? Could it simply be that your server/host does not have the best connectivity to Asia? How much time does it take when you ping your actual server IP address?

Thanks Sandro.

Here is the test link for the one i ran in Singapore: https://www.webpagetest.org/result/190730_P7_bef63b21e7f2a5e38d880da8f67b8bdf/

When i migrated over to vps few weeks ago it wasnt like that. it was really fast. I have many other sites under the same vps hosting server, is loading really fast here in singapore. they are not using Cloudflare.

You can also take a look at weddingplannersingapore dot net (i can’t post more than 1 link) under the same Cloudflare account also having same issue with exopetguides.

When i pinged my own server this is wad i get:
bytes=32 time=184ms TTL=52

Thanks for the link. I will try it out.

This topic was automatically closed after 30 days. New replies are no longer allowed.