Website page isn't working, could be dns could be ssl

I need help, tried a new ssl certificate. Changed from full (strict) to full, I am on the free plan if that makes any difference.

Please any help is appreciated.

The domain root erbasmedia.com is redirecting to the www subdomain and vice versa

$ curl -Is https://www.erbasmedia.com | grep -E '(HTTP|location)'
HTTP/2 301
location: https://erbasmedia.com/

and

$ curl -Is https://erbasmedia.com | grep -E '(HTTP|location)'
HTTP/2 301
location: https://www.erbasmedia.com/

It’s an infinite loop.

How do I fix this?

In addition to what @anon9246926 already wrote

This is not a good move, you made your site insecure in this way. Change that back to Full Strict.

Apart from that I’d go with @anon9246926’s advice.

Is this the issue you were referring to?

Still not working. Complete noob at this lol

Did you have that rule in place already, or did you just add it? In either case, I’d remove it.

If you pause Cloudflare, it set the records as DNS Only, does the site load correctly?

This is what is popping up now

Have you tried pausing Cloudflare so that requests go directly to the origin server?

1 Like

This is what happened when paused.

You might want to fix the SSL certificate.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.