Website not working properly on https

I have been using cloudflare for quite some time and never faced this issue, the website I am trying to route through cloudflare(http://beta.exportify.in) has been written in angular but it fails to work correctly(links not working, tabs not changing) when routed through cloudflare.

I think it has something to do with render blocking scripts.

Thata subdomain isn’t currently going through Cloudflare, so I can’t test it. But I do see that it doesn’t have proper TLS. You need to get that properly configured before you use Cloudflare TLS.

I have put the same website up through cloudflare on (https://testing.exportify.in), no links or tabs seem to be working

So…if you’re not running that subdomain through Cloudflare, it works?

For whatever reason, this turns up:

Thanks for the quick response, I have the same error on the http version but the website seems to work over there.

Hi, anything you can suggest?

I’m not sure how the coding is supposed to work, but looking at link, such as the Why Exportify? one at the top, I don’t see proper HTML for a link, but I do see: _ngcontent-gjn-c1, which looks pretty random and not something that contributes to the tag.

I suggest the following:

  1. Create a Page Rule that matches beta.exportify.in/* and then add a ton of features that are set to OFF (minification, caching, rocket loader, security, etc).
  2. Do a side-by-side comparison of the Cloudflare version and the non-Cloudflare version, looking for resources that may not be loading, and/or have different content.

Hi,

Thanks a ton I found that performance was creating a problem I tried turning it off for https domain and the links started working,

But how would turning the performance off affect the website in general?

The “Performance” page rule affects the following:

Turns off:

With that in mind, you can control these individually in the page rule. Then see which one is the problem. It’s probably Rocket Loader or Auto Minify.