Website not working! Please Help!

Answer these questions to help the Community help you get started.

What is the domain name?

Have you searched for an answer?

Please share your search results url:
I did not search

*When you tested your domain using the [Cloudflare Diagnostic Center]
DNS error. I do not know how to set up a DNS record.

Describe the issue you are having:
My wiki website will not load on my domain and I have no clue how to set up a DNS record.

What error message or number are you receiving?
The page would not load.

What steps have you taken to resolve the issue?

  1. Asked A2 Hosting support
  2. Asked Cloudflare support
  3. Asked the community

Was the site working with SSL prior to adding it to Cloudflare?
I set it up with Cloudflare (The domain)

What are the steps to reproduce the error:

  1. Set up the domain with A2

Have you tried from another browser and/or incognito mode?


Thank you for asking.

A2 hosting does provide you with web hosting services, correct? :thinking:

You should receive the IP address of the web hosting / origin host / server from them.

Therefore, upon registering for an Cloudflare account and adding your domain to your Cloudflare account, changing domain nameservers at your domain registrar making sure to point them to the associated ones which were provided to you in the process of adding your domain name to your CF account, you’d have to double-check the DNS records which were scanned and possibly added automatically. Otherwise, you can always view and modify them as needed.

My best guess is, correct? :thinking:

Kindly, navigate to the DNS tab of Cloudflare dashboard, therefore following the below step-by-step instructions from the helpful tutorial you can add the missing DNS A records pointed to the web hosting IP and being set to :orange: cloud.

I’d suggest you the useful tutorials to getting started with using Cloudflare:

Nevertheless, I can confirm and see your website loading fine from my end.

Furthermore, if you recently changed your domain nameservers, regular DNS propagation time usually takes up to 24-48 hours to complete.

May I ask have you tried using a different Web browser, or tried clearing your Web browser cache?
How about using a Private window (Incognito mode) or a VPN connection if possible?
Is it the same behaviour on your mobile phone (4G LTE, mobile data, cellular)?

1 Like

Thank you.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.