Website not working on Chrome


#1

Hello,

I have a website hosted on 000webhost. Before adding my website to Cloudflare it worked on all browsers including Chrome (which I used mostly).
After adding my website to Cloudflare my website stopped working on Chrome only. It still works on all other browsers (Firefox, Opera, IE).

On Chrome I can access my website but after I input my user and password in order to login I get this error (not other details):

1111111

Regarding Chrome: I have tried removing cache, cookies, deleted all content, reinstalled, tried on a different computer, even tried on chrome mobile app (by the way on the Samsung’s Internet browser it works). My website just doesn’t go past the login page on any type of Chrome Browser.

Is there any reason why this error happens only on Chrome?
What request does Chrome send during login? Obviously this has something to do also with Cloudflare since before adding it to Cloudflare it worked on Chrome.
How can I prevent this error on Chrome?


Bad Request in "only my browser"
#2

It seems that your server has a limit on the number of HTTP headers it accepts in any given HTTP request. Maybe Chrome sends more headers than the other browsers you’ve mentioned, and Cloudflare adding their own headers may have went above the limit.

If that assumption is correct, then the solution is simple: Modify your server configuration to allow a higher number of HTTP headers.

Note: This may also come from an app, or a “security” module of your server.

P.S. As for why does it happen only after a login - likely your login adds another Cookie(s), and another Cookie means another HTTP header added in the request.


#3

I have the same problem on my website - i use 000webhost and don’t know how i can modify server configuration.


#4

Looking more deep into it, seems like it’s managed hosting. So, assuming again it’s not a limitation imposed by your own app (written, e.g. in PHP), then there’s a good chance that you, yourself, cannot change it.

If I were you, I would open a support case to 000webhost, pointing them to this thread, and asking them to raise the limit for you. You’re not the only one with this issue in this host: https://www.google.com/search?q=000webhost+“The+number+of+request+header+fields+exceeds+this+server’s+limit”&filter=0&biw=1920&bih=1023


#5

I found a solution for this issue.
Indeed source of the problem is the limit of headers specified in the hosting server.
But also Chrome adding more headers than necessary.
I played around with the settings of Chrome and found that if you disable the Send “Do not Track” feature in Chrome my Website started working. Apparently this setting was adding the last drop.


#6

I don’t think it’s the right solution, because that means that at any one point in time someone might add a cookie or something else that you do not control - and then it will happen not only to you - but to all of your users (if it doesn’t already on some occasions, and you don’t know - and just lose visitors from Google!). Then you’ll have no way but to have the host change the limit, which they might refuse to do, and then you might find yourself needing to change a webhost - while everything is down, which is the worst time to do things like that.

I still think you should contact the host have them raise or even cancel this absurd limit.


#7

Yes, I finally found a proper salutation for this problem, i try lots of thisng even i re-install my browser, but the problem still there.
now i got the proper salutation.
And the salutation is “simply format you pc”
And Fixed :joy::joy::joy:


#8

No, the proper solution is to ask your host to remove this weird limitation from their side. It could very well be that you have users that can’t access your site due to this, and you’ll never know. When the issue is on the other side, you don’t workaround it locally so it will be OK just for you - you fix the issue where it actually is.

Solutions in the line of “format your PC” are perhaps the last resort for a very specific case of a very specific OS, where there is such thing as “non-fixable issues” (well maybe they’re fixable but only the vendor has the know-how which they don’t share) - so you have no choice. Here, this is certainly NOT the case. This is a deliberate action, the cause is known, and so is the way to fix it. (change the limit on the number of request headers on the server side)


closed #9

This topic was automatically closed after 14 days. New replies are no longer allowed.