Website not updating

Updates from wordpress are not appearing even after multiple CloudFlare cache purge.
Updates are viewable from within the building (network) but not available outside of these four walls (wifi) etc.

What’s the domain? @sdayman

May I ask is it related to content updates, or website updates like CSS, JavaScript, or rather plugin updates?

cache-control: max-age=315360000
cf-cache-status: HIT
ki-edge-o2o: yes

Are you using Kinsta for hosting your CSS, JS, images and other files?
If so, did you purged them at their origin (Kinsta) and at Cloudflare too?

For webpages I see (seems like you are using Cache Level: Standard as it should be):

cf-cache-status: DYNAMIC
x-kinsta-cache: EXPIRED

But on refresh webpage is being cached at Kinsta:

x-kinsta-cache: HIT

And I also see you are using Fast Velocity Minify plugin for WordPress to minify the CSS and save it at your origin due to the path /cache/fvm/min/.

Is Cloudflare configured using Kinsta integration or?

1 Like

Thank you for your help!
Hello its a content update and its with Kinsta.

So i need to refresh the cache at Kinsta correct?

After you made the changes try to:

  1. Purge/Flush it using WordPress plugin → to re-generate new files
  2. Purge it at Kinsta → so Kinsta would gather them new
  3. Purge it at Cloudflare (Purge Everything) → so Cloudflare would cache them new and serve the new too

It’s a bit complex because of it, but give it a try and wait for few minutes, then re-check.

Cleared the cache on Kinsta and Cloudflare with no luck.

Keep your browser’s Dev Tools (F12 in Chrome) open so you can check caching. If you see cf-cache-status DYNAMIC as @fritex showed, the content isn’t being stored by Cloudflare.

It could also be that your browser is caching the content and would need a Force Reload. Even Dev Tools have an option to Disable browser caching.

If it’s not your browser, you’re going to have to backtrack toward the origin. It’s definitely not Cloudflare caching the page content, but there’s a Kinsta cache. See if Kinsta can turn off their page caching.

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.