Website not updating on CloudFlare

#1

I have a client that is using CloudFlare on my recommendation. Their website is 200 static HTML pages, but I just did an “update” to a link in the top nav bar and their website is not showing the update. My local file is correct, the file dates on the server are the new dates, but CloudFlare is still showing old page - 3 days old as of this writing.

I asked the client to “purge everything” and they also set the cache time to 2 hrs, but the old files continue to show. Any ideas?

#2

What do the headers of the file say? Is the cf-cache-status there? What does it say?

Post a link if possible.

#3

Could be cached locally by the browser

#4

We cleared browser cache, tried it from several different devices in different geographical areas and tried it in incognito mode. We all see the same old, pages.

#5

I’m not seeing anything about cache in the header. The link is https://www.vlier.com - this issue is that the Mexico flag at the top right of the screen should be going to https://vlier.com/spanish_mx but it’s going to https://vlier.com.mx/spanish_mx. It seems the client did not maintain the vlier.com.mx domain. I fixed it, but we can’t get the site to show my fix.
Also, on the page source there is some javascript at the bottom that is supposed to redirect anyone coming to the site with vlier.com.mx to vlier.com/spanish_mx, but on the version I’m seeing it’s still sending to vlier.com.mx/spanish_mx - creating a 404 error.

#6

That page isn’t cached by Cloudflare, there are no cache headers since you don’t want caching there.

I guess there is some caching somewhere between your server and CF, but not on Cloudflare. Have you tried accessing the origin directly via the IP?

#7

Shared hosting and even using Vhost I cannot access this website by IP. I can see the files on the server, however, and they have the modified dates of when I made the changes that matches my local files.

#8

But are you actually sure those files have been modified? What is this date?

Try doing this substituting 127.0.0.1 with the original IP of your server, check if the file is updated:

curl --resolve www.vlier.com:443:127.0.0.1 https://www.vlier.com/

#9

Where am I supposed to enter this? When I type it into my address bar, I get Yahoo search results.

#10

Not in the browser, in the Linux/macOS terminal.

#11

I’m running Windows 10 and the server is an IIs

#12

Well then that command won’t work, would you mind sharing the IP (and then deleting the post if you want)? I could run it for you. Consider the possible implications, obviously.

#13

104.31.65.187 most html file dates should be 4/11/19 or newer

#14

That is Cloudflare’s IP, I need the origin one, not Cloudflare. Cloudflare is the one I get navigating directly from a browser.

#15

I don’t have the original IP all I have is “sky23,skyworld.com” to ftp

#16

What does the A record in Cloudflare say for www.vlier.com?

#17

okay, try 18.217.93.88 or 18,223,95,150

#18

I don’t have access to their CloudFlare account - otherwise I would be clearing cache like crazy instead of just the single purge.

#19

Yeah, but that isn’t really necessary, a single or a couple purges would be great. At this point you and I can’t do much more. You need to check what the server actually replies which I believe is what Cloudflare returns.

Since you aren’t the owner of the CF account you can’t open a support ticket and I doubt @cloonan nor @cscharff can share details. Maybe they can confirm my idea, but nothing more.

#20

Thanks, I sent an email to the hosting company to make sure they didn’t move the site and forgot to tell us. I can upload the files, but no one can see them.

1 Like