Website not showing when Connected to local ISP

Hi Everyone,

I created a website www.coralceilings.mu

It seems to be appearing and working all over the world except when I am connected to my local ISP (Mauritius telecom)

I get this message:
www.coralceilings.mu ’s server IP address could not be found.

DNS_PROBE_FINISHED_NXDOMAIN

Does anyone have a solution for this? I contacted my local ISP but it takes them months to answer any requests…

Kind regards,

Ludovic

Can you post the command line output of the following commands?

ping coralceilings.mu
ping www.coralceilings.mu
nslookup coralceilings.mu
nslookup www.coralceilings.mu
nslookup coralceilings.mu 1.1.1.1
nslookup www.coralceilings.mu 1.1.1.1
nslookup coralceilings.mu 8.8.8.8
nslookup www.coralceilings.mu 8.8.8.8

Hi Sandro,

this is what i get when connected to my ISP:

Administrators-MacBook-Pro-2:~ l.barbot$ ping coralceilings.mu

ping: cannot resolve coralceilings.mu: Unknown host

Administrators-MacBook-Pro-2:~ l.barbot$ ping www.coralceilings.mu

ping: cannot resolve www.coralceilings.mu: Unknown host

Administrators-MacBook-Pro-2:~ l.barbot$ nslookup coralceilings.mu

Server: 192.168.100.1

Address: 192.168.100.1#53

Non-authoritative answer:

*** Can’t find coralceilings.mu: No answer

Administrators-MacBook-Pro-2:~ l.barbot$ nslookup www.coralceilings.mu

Server: 192.168.100.1

Address: 192.168.100.1#53

** server can’t find www.coralceilings.mu: NXDOMAIN

Administrators-MacBook-Pro-2:~ l.barbot$ nslookup coralceilings.mu 1.1.1.1

Server: 1.1.1.1

Address: 1.1.1.1#53

Non-authoritative answer:

Name: coralceilings.mu

Address: 104.28.3.43

Name: coralceilings.mu

Address: 104.28.2.43

Administrators-MacBook-Pro-2:~ l.barbot$ nslookup www.coralceilings.mu 1.1.1.1

Server: 1.1.1.1

Address: 1.1.1.1#53

Non-authoritative answer:

Name: www.coralceilings.mu

Address: 104.28.3.43

Name: www.coralceilings.mu

Address: 104.28.2.43

Administrators-MacBook-Pro-2:~ l.barbot$ nslookup coralceilings.mu 8.8.8.8

Server: 8.8.8.8

Address: 8.8.8.8#53

Non-authoritative answer:

Name: coralceilings.mu

Address: 104.28.3.43

Name: coralceilings.mu

Address: 104.28.2.43

Administrators-MacBook-Pro-2:~ l.barbot$ nslookup www.coralceilings.mu 8.8.8.8

That seems to be a propagation issue.

Is 192.168.100.1 your router? Try restarting it, which might flush its DNS cache. If that still does not work you can only wait until it resolves or you change to another resolver. For example, Yandex or Cloudflare.

It is my router. However Many different people on the island on having the same problem as me on different routers. I am already using Cloudflare.

Assuming you have the same ISP as these other users it must be the ISP.

And no, you are not using Cloudflare’s resolver as that would work otherwise. If you resolve specifically against Cloudflare it obviously worked, your default settings dont work.

Test has been done from and details below:

Home network Mauritius Telecom ip 197.227.150.221
tracert www.coralceilings.mu
Unable to resolve target system name www.coralceilings.mu.

Business network Mauritius Telecom (ip : 41.212.220.237)
Tracing route to www.coralceilings.mu [104.28.2.43]
over a maximum of 30 hops:

1 <1 ms <1 ms <1 ms mediatiz.localdomain [192.168.12.1]
2 <1 ms <1 ms 1 ms 192.168.11.1
3 4 ms 4 ms 4 ms ADSL-220-1.myt.mu [41.212.220.1]
4 4 ms 3 ms 4 ms 196.20.239.106
5 4 ms 5 ms 4 ms 197.226.230.18
6 5 ms 15 ms 5 ms 197.227.88.10
7 3 ms 4 ms 4 ms 104.28.2.43

That doesnt tell us much. But if you are saying several users who share the same ISP experience the issue it is very likely because of the ISP.

Thank you, Sandro. My ISP is another story though! Before I get hold of them to explain I can wait for weeks… :frowning: