Website not loading with "https" after changing the DNS


Please my website is not loading with the “https” and showing “insecure connection”. This is after I have changed the DNS to Cloudflares for more than a week.

I registered the domain with namecheap and used a different hosting provider, could that be the cause?

I have changed the DNS of other sites and they worked perfectly, except this.

Your suggestions of what I should will be greatly appreciated.

1 Like

What’s the domain?

the domain is

It does work with HTTPS, so go to Cloudflare’s SSL/TLS settings page and scroll down to enable “Always Use HTTPS” and “Automatic HTTPS Rewrites”.

1 Like

Done. Thanks a lot. Sdayman

1 Like

This topic was automatically closed after 30 days. New replies are no longer allowed.