Website not loading after addiing: Shows 'Directory Listing'

I have added my website fouaad. com to Cloudflare. The DNS settings have been updated but my website is not loading. When I lookup www.fouaad. com, I see a blank page saying 'Directory Listing.

I have added my other website hunzastate. org to Cloudflare and it is working fine. But the other one is not.

My hosting for both websites is with namecheap and the domains are originally registered with godaddy.

I can’t seem to find an answer for this exact same problem. Please help, thanks.

So far, I have not received an error message from the flare.

Attached is the screenshot of the error.

Thank you for your help.

Have you searched for an answer?
I can’t seem to find an answer for this exact problem.

Did the site work fine on HTTPS before?

Yes it did. I have a namecheap SSL certificate.

All right, are you sure you have the correct address configured? Can you pause Cloudflare and verify that it loads without the proxies?

I have not tried that. But it was working perfectly before I added it to Cloudflare. Also, the other website I have added is working good.

And I have not done any manual address config. I only went ahead with the default proxies Cloudflare had set.

Should I pause it?

Yes, I would pause it.

Pause it but still the same error.

What does the ‘directory listing’ mean. Where is this page coming from, is it from the hosting or from the domain registrar.

I think the domain is not pointed towards the hosting, but where do I fix it?

You have two issues here.

  1. You have an insecure encryption mode on Cloudflare and essentially no security.
  2. You have the wrong address configured.

To fix that

  1. Change your encryption mode to Full Strict.
  2. Make sure you have the correct IP address configured in the DNS settings.
1 Like

I enabled full strict mode and it worked. Thank you very much for the help. :heart::raised_hands:

Are you entirely sure? I still get the directory listing. Did you fix the addresses?

The right encryption mode is important, but not the only thing.


For anyone else having the same problem, here’s how to enable ‘full strict’ mode.

Umm yes, I have purged cache and rechecked to see the site live again.

Hmm, sitemeer.com/#https://fouaad.com/ also still gets the directory listing (-> 904 bytes).

Did you fix the addresses?

I have not reconfigured the adds. Sitemeer is saying the site is up here.

It is up, it was up before, but it’s still the directory listing.

Again, fixing the addresses is equally important to the encryption mode. You only fixed the first thing, but not the second. You need to make sure you have the right address on Cloudflare.

1 Like

This A record was different than what it was in my hosting. I have now changed it to the one in my hosting and I belive this is working.

Yes, that should be correct, but also make sure that your naked domain is properly configured as well, because I believe that had the other address as well.

1 Like

You mean the first CNAME record, because I think I have to change that too. Its different than the one in my hosting.

No, not the _acme-challenge (you probably don’t even need that for now) but rather the naked domain, unless I am mistaken you had two addresses configured there.

1 Like

yeah, the _acme is from my previous hosting.

But the naked domain is routed the properly though,