Website not Caching on Cloudflare

It looks like Cloudflare stopped serving cached images of my site on June 14. Coincidentally, that’s the same day that Jetpack and Google Analytics stopped tracking my stats.

Hi, can you please provide some additional information about your site? A url will be helpful.

1 Like

Oh no, sorry I missed that. My website is I contacted WP help, and they said there were a conflict between Jetpack and Cloudflare. I’ve been trying to debug this all week, and have spent about 30 hours on different actions, but now it seems to point to a problem in Cloudflare, although I’ve had the two (CF and JP) running on my site for years.

For me it seems like the images are cached right from Cloudflare. This can be verified with the developer tools of your favourite browser browser.

In chrome navigate to the Network tab and then enable the Img filter. After reloading the page in the list below there should be some images embedded into your website. Click on one of them. Then open the Headers tab in the sidebar. Under Response Headers there is the following header:

According to the Cloudflare documentation the value HIT for this header means that the image was cached by Cloudflare.

The output of the CF-Cache-Status header shows whether a resource is cached:

HIT The resource was found in Cloudflare’s cache.

From Cloudflare Support Center Section Understand Cloudflare cache responses

As I said for me it seems like the Cloudflare cache is working. I hope this helps.


Thanks! I’ve been working on it all afternoon, and I think I managed to tweak some things that are helping to get the cache working again. But I still haven’t fixed the conflict with Jetpack.

Can you please provide some more details about the conflict? What exactly do you mean with “conflict” and what have you already tried to solve the issue?

My Jetpack only records 1-5 views a day, instead of the hundreds I’m getting, which GA is still tracking. Jetpack support said “I see that your site is behind Cloudflare (a CDN and DDoS protection service), which may be contributing to this issue.” I’ve tried reconnecting and reinstalling the Jetpack plugin several times, allowing rules in Cloudflare to disregard the plugin, disabling all other plugins, restoring a backup of my site, consulting over a dozen people on Fiverr, writing to support at Jetpack, Wordpress, and Siteground, and quite a few other things which I’m having trouble listing at the moment.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.