Website not being cached - can't figure out why

wordpress

#1

Hi, newby question here : )

I’m hosted in a dreamhost server that includes a varnish cache. This cache has been conflicting with my content so I started fiddling with some setting to resolve it.

I added a few rules and set developer mode on until I could figure a way to deactivate varnish from my dreamhost server altogether. Once I got that done I tried to bring cloud flare back to normal but never got it to cache again.

I’m running “curl -svo /dev/null http://laubergehotel.com” to check the status and I’m getting a not-cacheable message.

Any support would be very appreciated!


#2

That “Not-cachable” is coming from your server. Maybe that’s Varnish.

Your static resources (.js, .jpg, etc) are caching.

HTML pages, whether it’s from PHP or static .html is not cached by default. Having Cloudflare cache it by using a “Cache Everything” Page Rule is risky on WordPress because of the dynamic content.

I suggest you start with just one Page Rule: Match “laubergehotel.com” and add a Setting for Cache set to “Cache Everything” and a second setting for “Edge Cache TTL” of 1 day.


#3

My opinion is you do not need to cache your HTML. According to this waterfall view, the / part of your site loads quickly (thanks to your server). Most of your site loads in less than one second. It’s all the video resources from Google and Youtube that pushing it to 2.5 seconds. Even then, the site presents itself quite quickly. The 6.2 MB of data will be a problem for people on slower connections.

To sum up: less video will speed up your site. Everything else is good.


#4

Oops, I forgot to attach the link from the performance test I ran: