Website Link Preview Not Working

Hello,

When posting our company website link on any social media site (Facebook/Twitter/etc.), there is no image on the link preview, despite selecting a featured image in Wordpress. This is for every page on our website, old and new. The links work, but no preview image or text is displayed.

When I contacted Wordpress support, they suggested that it was an issue with our Cloudflare account.

Any help is appreciated, thank you.

Have you tested your links with the Facebook Sharing Debugger yet? It’s a good place to start.

I just did, and the warning that shows up is as follows:

"Could not follow redirect: URL requested a HTTP redirect, but it could not be followed. "

It seems to be the http/ https issue. By forcing Always https and other settings, can make a difference.

1 Like

Thank you for your response. How would I do that on Cloudflare?

Hi there, I hope you have solved the issue. If not, try this: select the website, move on to SSL/TLS tab. Look into edge certificate. You’ll find. Also, check how your webserver is communicating with Cloudflare. To do so, look into the Overview tab.

Hi,

It seemed that turning off the “always use https” option in the SSL/TLS > edge certificate tab solved the issue. Thank you for your help.

Nice to hear. You can mark it as issue solved.