Website keeps showing old version

My website keeps loading previous (and ugly) versions of my page. I don’t have any cache plugins activated and I have purged CloudFlare cache several times, so I don’t understand why this is happening.

For instance:

  1. When I click any of the top menu links of my home page https://bablingua.com/ they sometimes load correctly, but sometimes they don’t.
  2. If they load correctly, when I click a link in that new window and then press the back button, I’m always redirected to the old version of my site.

Any help will be highly appreciated!

That doesn’t sound like it’s coming from Cloudflare, and I see that Cloudflare is not caching that page, as it won’t by default.

Have you tried clearing your browser’s cache or a different browser? How about a different device?

This test shows consistent views around the world:
https://www.dotcom-tools.com/website-speed-test.aspx#136C6A3723B541C5B5811D257466B805

Thanks for looking into this. It’s definitely not a browser’s issue: I’ve tried in many devices and I’m getting many emails from visitors to the site that keep hitting that old nasty version.

This is what I’ve found so far:

  1. When I visit a page that existed in my previous theme it loads well. When I reload it, it goes to the old version: https://bablingua.com/recursos/nivel-inicial/
  2. If I purge the Cloudflare cache, it solves the problem… until I reload the page.

I’m able to replicate that, but the bad version has a lot of b-cdn.net resources. Where is that coming from? If that’s a LiteSpeed CDN setting, can you try turning that off? You don’t need a CDN if you’re already using Cloudflare.

I also see the page shows a LiteSpeed cache hit. So you are using a Cache Plugin. Generally, LiteSpeed cache is safe, but try purging all LiteSpeed caches and see if that helps.

Thank you so much!! My hosting provider installed two cache plugins at a time when my website was really unstable.

I’ve started everything from scratch, and I’ve uninstalled both LiteSpeed CDN and BunnyCDN. I guess what happened is that there are some leftovers after the installation.

I hope it’s not too much asking, but could you give me some information about how to get rid of everything related to those plugins?

Thanks again!

Álvaro

This topic was automatically closed after 30 days. New replies are no longer allowed.