Website is not working anymore! Too many Redirects?

Hello Guys,

My Website: Janfitschen . de just crashed.

I cant access Wordpress. I tried chaning the SSL/TL to flexble, off, strict nothing worked.

I deactivted my Wordpress Caching Plugin. Nothing seems working.

I dont have SSL installed on my origin Server.

Can Somebody help me?

Turn off HSTS, Always Use HTTPS and SSL/TLS Recommender then access your site in another device (incognito tab is recommended because otherwise browser will save ssl configuration and affect debugging)
You should use Flex mode if you don’t want to install ssl on your server. I do not recommend this.

I understand you discouraged the OP from choosing that mode, but that mode should actually never be used. The OP should pick Full Strict.

1 Like

Hey thank you so much for your fast Reply!

I change everything like you told me.

HSTS was never turned on, put always use HTTPS and SSL Recommender on. Still the Site is not accessible?

What am i doing wrong?

Your site is still redirecting to HTTPS Protocol
Try Purge Everything in Caching Configuration

Purged the Cache still not working :confused: Is there something else i can try?

I’m pretty sure the error is caused by “Always Use HTTPS” or “SSL/TLS Recommender” if it’s Cloudflare’s fault.
If not, it’s probably your server. Try checking any configuration on your server that automatically redirects HTTP traffic to HTTPS.
Or you can try checking your “Page Rules” if you accidentally enabled any SSL related options

I fixed it.

i need to change my wordpress url to http instead of https in phpadmin. Now i can connect to the website.

But my whole wordpress backend is screwed? What can i do? Why does it affect my wordpress?

You can change the URL to HTTPS now (since you using flex ssl now right?)

And whitelist your server ip and any server of whatever plugin you’re using (try bypassing the entire IP using the following rule to see if it works, delete it as soon as debugging is done)
If it works fine, you will know what the problem is.

Hang on, you didn’t fix anything, you just made your site even more insecure.

That’s your actual issue.

I suggest you pause Cloudflare for starters and fix the site first. Then you can use Cloudflare.

So should i install a SSL on my Origin Server? (Shared Hosting Account)

Should i actiavete Force SSL on my origin hosting account?

Which Setting should i use in Wordpress? http or https?

I dont understand

Of course you should install SSL on your server, otherwise the site cannot be secure.

As I mentioned, pause Cloudflare and contact your host to get your site working properly first.

I talked to my host like 10 minutes ago. But they wont help me because they say my website is no on there Server anymore and is hosted on Cloudflare :confused:

Well, apart from the fact that Cloudflare is not a host and does not host your site, I’d ask the host in that case what they are charging you for, if they claim not to host your site :wink:

Probably a good idea to change host. Anyhow, have you paused Cloudflare already?

1 Like

yea the host suck. In Germany almost every host sucks :smiley:

I installed a free SSL Certifitacte on my origin Server and turned the SSL Setting in Cloudflare to Full.

Is this enought?

1 Like