Website is not reachable with proxied DNS

Answer these questions to help the Community help you with Security questions.

What is the domain name?
I am comfortable to share this info in private chat.

Have you searched for an answer?
Yes, I do not find a question that matches the problem experiencing

Describe the issue you are having:
My website is not reachable with proxied DNS. However the website was working before on port 443, secured using SSL certificate from Letsencrypt. Also the website is reachable and working when the DNS is not proxied.

What error message or number are you receiving?
Please see the attachment.

What steps have you taken to resolve the issue?

  1. Turned off SSL/TLS in Cloudflare. Later realized that its not appropriate

Was the site working with SSL prior to adding it to Cloudflare?
Yes, the site was working with SSL creating using Letsencrypt

What are the steps to reproduce the error:

  1. Access the website with proxied DNS, it won’t work
  2. Disable the proxied DNS and access the website, it will work

Have you tried from another browser and/or incognito mode?

  1. Yes the behavior is same irrespective of browser/incognito

Please attach a screenshot of the error:

Thanks for the response. Let me know what you think could be the problem

That hostname returns an NGINX setup screen:

You can also test reachability here:

I do not a see consistent correct result (i.e. nginx page) across devices. is it a cache issue at Cloudflare?

No. It’s some sort of network issue, which is why I recommended the Uptrends test.

When i ran in the browser with a hostname where the nginx is also hosted, i get an error. why?

Because there’s a problem.

I tested from a browser in another computer. It does not work but works from all mobile devices. Does Cloudflare provide any technical support?

Not for personal computers and local networks. It loads in my browser, and there are no errors in a global test. Best to try a traceroute from any device that can’t connect, and see where the connection is failing.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.