Website is down. please help!

dns
cname
wordpress

#1

Hi there

My website is down. I have recently changed my hosting server and it is causing the website to be down.

Can you please advice me on what I need to do next to use cloudflare with my changes to the hosting server?

Website name: opsec.co.nz

Updated the A-records to the new server IP address? Is there anything else I need to change?

Thanks


#2

Does your new server have a proper SSL certificate for your website? My guess is “no.”

From the Cloudflare Crypto settings page, try changing your SSL to “Flexible.”


#3

Please define proper SSL certificate?

This is the kind of SSL certificate which is activated on our new server:

https://www.sslshopper.com/ssl-checker.html#hostname=opsec.co.nz

We are using the same SSL certificate as previously and it worked fine before we changed servers.

Although, I am able to access part of my website however, some pages are not working for example, opsec.co.nz/about-us page and previous redirects. I am also unable to login to my admin panel.

Apparently everything works fine from the hosting end. They say that something is wrong with cloudflare.


#4

Technically, your website is not down, however it keeps redirecting to itself which enters an endless loop and doesnt display the content either of course.

By “proper certificate” sdayman was referring to an officially trusted certificate signed by a certificate authority. https://crt.sh/?id=588269285 would suggest you applied for a certificate on July 10th. Is this the one you have in place?
What is “SSL” set to in your domain’s “Crypto” section?


#5

it appears to be that one yes. The SSL set in crypto’s section is set to “flexible”.


#6

Well, it does seem to load now. Have you made any changes?


#7

Yes it loads now but the about us page doesn’t load and the website doesn’t load from the cellphone either and I cannot access my website back-end either.

I changed the SSL settings from full to flexible as suggested earlier.


#8

Considering you changed it to Flexible and it works, I’d rather rule out a TLS issue (or HTTP/HTTPS redirection loop) but there must be some misconfiguration on your server. Its difficult to analyse this remotely, I’d pass that to fix to whomever manages your site.


#9

Well, I manage the website and the hosting company says that they have done the configuration right and everything is fine from their end and asked me to check with you guys as my domain name is pointed to cloudflare servers.

I also, changed the A-records under DNS settings.


#10

Well, Cloudflare is unlikely to be the reason for that. You must have somewhere a redirect that is going in circles, initially it was on the main page too, that seems fixed now but the about page still redirects. You seem to use Wordpress, so check its settings as well and try to retrace your steps, in regard to what you changed for the redirect to disappear from the main page.


#11

it seems it works properly


#12

well, it was updating the DNS entries and changing the SSL status from full to flexible.

One of the customer representatives from the hosting company suggests that I should install the SSL under origin certificate otherwise the SSL won’t work.


#13

Its not fully working mark


#14

Configuring an origin certificate might not be a bad idea, but it all depends on what your current configuration is. If you request an origin certificate from Cloudflare and install it, you could switch to “Full SSL Strict”. Maybe this will fix your issue, but no guarantee :slight_smile:


#15

Can you define “current configuration”?


#16

The configuration of your webserver.


#17

How is the configuration of the server has anything to do with SSL certificate?


#18

Its only the place where you configure the certificate :wink:

No offence, but please read about the subject, otherwise we will be going in circles, pretty much like your webserver :slight_smile:


#19

hahaha non taken I do understand the configuration bit but I thought you meant something else when you talked about server configuration.


#20

I was referring to the overall configuration, that involves the TLS certificate, ports, any possible redirects configured in the server itself or possibly sent from the application.

I dont know your setup, so I cant say where this “eternal” redirect :slight_smile: originates but something got fixed earlier as it does not redirect on the main page anymore, but still on the about page. Thats going to be good old debugging I am afraid.