Website is down because of some SSL issue

ssl

#1

My website dailytitan.com is down and it is giving me this error:
The requested URL /about/ was not found on this server.
Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

I contacted the Domain Hosting Company and they told me that CloudFlare has some problems with SSL certificates installed their end. Ask them to solve the issue.

Dont know what to do. Please help! Thanks in advance!


#2

I’m not seeing an SSL problem, and the /about/ page works for me, but I’m seeing a lot of other problems, mostly with .js

Just as an experiment, can you turn Rocket Loader “off” in your Cloudflare Speed settings? Maybe someone else can chime in with what the JS issue may be.

I’ve also never seen so many calls to wordfence. Do you have Live Traffic view turned on?


#3

Hello,

I just turned it off. Can you check now? Is it working fine or not? Let me know asap,

Thanks

Ameya


#4

I’m not seeing the tons of errors and Wordfence calls, but the site still isn’t showing thumbnails.

Could you check your Auto Minify on the Speed settings page? It may be a CSS minification issue, but for now, turn off CSS, HTML, and Javascript minification. Then go to the Caching settings and Purge Everything.

None of the settings I’m having you disable is going to weaken Cloudflare protection or SSL, so we can turn them on as we eliminate them as a source of the problem(s).

And, just to clarify, when did this all stop working? What changed? Did you just add it to Cloudflare, or did just enabling SSL do it?


#5

Hello,

I just did what you said. The images and thumbnails are still not displaying. I dont know the root cause. it is happening from morning. The website has been up and down multiple times. The website is hosted on cloudflare from many years. And SSL was I think enabled before as well but I am not sure right now. Hope you find the root cause. let me know what should I do next.

Thanks
Ameya


#6

Hello,

The website when accessed from mobile works fine but when we access it from Laptop/Desktop it is not showing any images. I am not able to find out what the root cause is. Need help asap. I have traffic accessing my website. Need urgent assistance and help!

Thanks
Ameya


#7

I’m stumped. There’s just something about the responsive layout that’s not making it through Cloudflare. Are you using any Page Rules?

I still think it’s CSS. How about a Page Rule:
Match dailytitan.com/css
Add setting for Cache Level: Bypass.

Then Purge the cache. My theory is your site is sending CSS based upon the browser, and CSS files are cached, so mobile users are getting a cached version that works, but that mobile CSS file doesn’t work for desktops. Just a theory.

Hopefully someone might drop in and offer some advice: @MarkMeyer or @matteo?


#8

Give me 5 minutes and I’ll check… It’s late here on the other side of the Atlantic!


#9

I cant see any thing that dosnt’ load.

The pictures disappear immediately when I change the widtdh of the Chrome Dev Tools (no page reload).
I guess there are some issues with a (java) script. The console is showing some JS errors. But i don’t know what they do.

As you can see I didn’t change the width that much.

Waterfalls:

Chrome Mobile:
https://www.webpagetest.org/result/180510_RJ_59d28ec6a217f31f9ff25e3e376ba4d4/2/details/#waterfall_view_step1

Chrome Desktop:
https://www.webpagetest.org/result/180510_K0_3ed118648656a5fb63a0f2f1843a6283/1/details/#waterfall_view_step1

I cannot see any difference. I for my self can’t imagine that this is Cloudflare related. Did you do some changes to the theme recently? (Auto update, manual changes…)


#10

Thank you guys for helping me out! No I did not made any changes to the theme! I dint even made any updates to the theme recently.


#12

I believe I found the issue, which exactly what @MarkMeyer shows in its screenshots.

That script you are loading directly from raw.githubusercontent.com fails to load, obviously. You should host it yourself and not load it from GitHub (from there they do not allow loading).

Loading directly from GitHub fails because it’s not served as a script.

Additionally you should NEVER load something from a location which can change both for security and usability reasons. You should at least use something like https://cdnjs.com/ or https://www.jsdelivr.com/, ideally with SRI.

More info:

https://scotthelme.co.uk/protect-site-from-cryptojacking-csp-sri/


#13

So is there any fix that you can suggest me! I dont know much in this area. So guidance will be really appreciated! Thank you so much.


#14

That external Javascript call still stumps me. I don’t think it’s been updated in over 4 years.

When did this problem begin? I thought you said it was very recent, like in the last morning or two.

As for the script that’s not loading from Github, if you can find out what’s calling it (I can dig deeper later), you can use this URL instead:
https://cdnjs.cloudflare.com/ajax/libs/equalize.js/1.0.2/equalize.min.js


#15

Thank you so much for your help. Yes the problem is occuring from yesterday morning. Sure I will try it out! I am also still trying to find out what’s calling that js. Is there any way to find out.


#16

I don’t know how to open a new forum. I have a question about ssl as well.


#17

nevermind


#18

Once and for all, I’d like to see if this is a Cloudflare issue or not. Can you go to the Overview page in your Cloudflare account and use the Advanced settings to Pause Website? This won’t stop your website from working, but it’ll pause the Cloudflare services.

Give it ten or so minutes to settle in, then see if your site’s images start showing up again.


#19

I saw you were replying, but now that I check, the site looks good. Did you change something?


#20

Hello,

The website images are showing again. Thank you so much, guys!! The problem was the JS you guys pointed out @sdayman @matteo @MarkMeyer… thank you so so much for your time and efforts! Kudos to you guys! I fixed it and boom the images are back again!! I have last question to ask, that my WordPress backend access shows Not Secure in the address bar. How to change it back to Secure?


#21

I’d go to Cloudflare’s Crypto Settings and make sure you’ve enabled: “Always Use HTTPS” and “Automatic HTTPS Rewrites”

If that doesn’t cure it, it may be a Mixed Content issue. Post back if it’s still Not Secure.