Website inaccessible after changing nameservers to Cloudflare and adding a TLS Certificate


#1

My website and my WP Dashboard are both inaccessible after changing nameservers to Cloudflare and adding a TLS Certificate. Not sure whats the problem, but it has been over 36 hrs now. Have written to support but no response from cloudflare. Need solution ASAP.


#2

Not sure what inaccessible means and it helps if you provide details (site and possibly an error message) if you are looking for community assistance.

At the moment you have Cloudflare paused which means we’re going direct to your origin server. It’s quasi-inaccessible in that you have an origin certificate from Cloudflare installed (which is good) but that certificate is trusted by Cloudflare’s edge not a normal browser and is intended to be used when traffic is being proxied through Cloudflare (which it currently isn’t because Cloudflare is paused).

Also you have a number of records orange clouded for protocols which Cloudflare does not support (e.g. FTP & SMTP). Cloudflare will only proxy http/https and websocket traffic.

Additional information would be required if you still need assistance.


#3

The entire website was inaccessible which was finally rectified after a long while. I have paused it since resuming will again make my site inaccessible. Possibly because of some misconfigurations like the ones you’ve mentioned above.

It will be helpful if you can tell me which protocols should I not let through Cloudflare. Also the SSL is not properly functioning since the browser throws up a warning which is worse than not having a certificate.

Some tips on this would certainly help.


#4

Inaccessible meant, the website and the WP Dashboard was either showing up with a ‘white page’ or an error(502,504) or ‘not found’. It works now, but I need some assistance in configuring the DNS Protocols on Cloudflare before resuming and hope this will resolve the browsers throwing up the security warnings.


#5

Hi. Are you willing to re-enable Cloudflare and share your URL so the community can take a look?

Leads me to believe you have a mixed content issue. Your DNS setup is likely fine, though it’s impossible to tell at this stage.


#6

Hi… sure… www.raagamorph.com is the url and I’m re enabling cloudflare now.


#7

At the moment your crypto is set to flexible, but should be set to full or Full (strict).


#8

Ok I have set it to strict. Yet the padlock lock appears and disappears


#9

I’m seeing :lock: in my browsers (Firefox, Chrome & Safari). Which browser are you using? You may need to clear cache and/or test in a private tab.


#10

Thats right…! I see it too now… Guess the setup is just fine…! Thank you.


#11

is there a tool that can be used to check for mixed content in a page that you could’ve missed


#12

Sure. You can use your browser’s dev tools - typically right-click on the page and select ‘Inspect’ to open them up.

Both Safari and Chrome provide a ‘quick alert’ for mixed content, which looks like:

caution1
or
safari
You can click these icons and the browser will give you a summary of the warnings/errors, listing the asset(s) that aren’t coming across via https.

Firefox doesn’t have this type of alert that I know if, instead I just look at the ‘network’ tab of the devtools for any missing :lock:


#13

There’s also

https://www.whynopadlock.com/


#14

Yes… I did use https://www.whynopadlock.com/. Its a cool tool. Obviously, the dev tools in browsers are quicker…