Website goes down after changing nameserver to Cloudflare nameserver with 404 errors


Changed nameserver to Cloudflare nameservers and now I’m getting 404 errors. It’s been longer than 48 hours. If I turn off the Cloudflare proxy in the DNS control panel everything starts working.

Attached is what my DNS records are set to in Cloudflare. Website is hosted at HostPapa at 69.90.66.40
If I turn off the Proxy setting it works again. I have the Proxy turned off when I need to use the site.
DNSSEC is not enabled.

Any ideas on how to fix this?

Can you post a screenshot of this 404 error page showing?

Usually 404 error comes from the origin host / server.

From below link:
https://support.cloudflare.com/hc/en-us/articles/115003014512-4xx-Client-Error

404 Not Found ( RFC7231 )

Origin server was unable or unwilling to find the resource requested. This usually means the host server could not find the resource. To serve a more permanent version of this error one should use a 410 error code.

These errors typically occur when someone mistypes a URL on your site when there is a broken link from another page, when a page that previously existed is moved or removed, or there is an error when a search engine indexes your site. For a typical site, these errors account for approximately 3% of the total page views, but they’re often untracked by traditional analytics platforms like Google Analytics.

Website owners usually implement a custom page to be served when this error is generated.

Cloudflare does not generate 404s for customer websites, we only proxy the request from the origin server. When seeing a 404 for your Cloudflare powered site you should contact your hosting provider for help.

What exactly happens when you switch from :grey: to :orange: cloud?

Furthermore, was your Website working over the HTTPS connection and have had an valid SSL certificate installed at the origin host / server before you have moved to Cloudflare?

Here is a way to re-check if you correctly setup the SSL for your domain with Cloudflare:

I can access your Website over HTTPS - still :grey: cloud (DNS-only).

Kindly, re-check the which SSL option have you got selected under the SSL/TLS tab of Cloudflare dashboard at your Cloudflare account for your domain name.

It should be set to correct one, Full (Strict) SSL, here is why:

I suggest you use the “Pause Cloudflare on Site” option from the Overview tab for your domain at dash.cloudflare.com. The link is in the lower right corner of that page. Give it five minutes to take effect, then make sure site is working as expected with HTTPS. Only then should you un-pause Cloudflare and double-check your SSL/TLS setting to make sure it’s Full (Strict).

1 Like

Capture2
I have set the proxy back on again and this is the screen shot of the 404 error.

May I ask have you also tried clearing your Web browser cache or trying to access via Private Window or some other Web browser (even different network like mobile data)?

I still see the origin IP, seems it’s not proxied. Can you leave it proxied :orange: so we could check from our end too if any difference(s)?

I turned on the proxy. So far it seems to be working on my end. Not sure exactly why it has started working though.

All I did recently was finish adding in the MX records. Maybe that helped?

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.