Website Forms Submission broken when Cloudflare is Active

Forms Submission button stays 'Spinning'.This occurs only on front-end, Live site with Cloudflare active. (Fig. A)

  • Hosting: Cloudways
  • CMS: Wordpress & Bricks Builder Theme
  • Email: Rackspace Addon w/ Cloudways

Here is my DNS Settings (Fig. B)

Forms Submission works only in:

  • Wordpress back-end, communication with Email is working.
  • Staging Site.
  • Live Site but ONLY in Mozilla Firefox? (Fig. C)

Any help is appreciated, thank you!

@russ3 Hi Russ, I saw you ran into this issue as well without a solution in your thread.

Did you find any fix? Thank you

@cloonan Looks like you had an opportunity to help support this kind of issue. I’ve narrowed the issue to Cloudflare, Form Submissions work correctly when Cloudflare is ‘Paused’. Any Ideas how to fix this issue?

Tagging other users that have ran into this issue without solution in their thread. Has anyone found a fix for Cloudflare blocking Forms?

@CFuser22 thread
@pcmmedia thread

I’ve tried purging Local cache and Cloudways Cache using Varnish. No luck :confused:

Hey @saul it looks like you have experience with debugging Forms not working with Cloudflare. For a brief summary, when I disable CF, my form submission works. When i have CF enabled, my Forms submission is broken.

Any help is appreciated

Hey @russ3 I’ve learned a little bit more about my problem.

  • Forms works only in /wp-admin mode
  • when I logout of /wp-admin, the form continues to work.
  • when I clear cookies and site data, Form stops working.
  • Cannot submit Form in any browser unless logged in as /wp-admin and cookies and site data is logged

Cloudflare Zero Trust - wp-admin rule breaks Bricks Builder Forms!

Clicking Forms Submit button an http request is sent out to .com/wp-admin/admin-ajax.php which redirects user to Cloudflare Zero Trust 2FA.

Disabling wp-admin rule, and Forms Submission works fine.

Glad you’re sorted. Yeah, any Cloudflare ‘catching’ of an endponit is a gotcha for this kind of thing - so Cloudflare WAFs, ZT rules, even rate-limiting etc. Though I am surprised a form would need /wp-admin paths (unless it’s admin form of course, lol).

Yea… it’s not an admin form… hmm. It’s for public use.

I’m using Wordpress Bricks Builder Theme and it’s Form element. I’ll have to look into it some more

I am using RSForm Pro with Joomla and found out that I was having this problem, mainly with MS Edge browser submissions. I SOLVED it by excluding my catalog submission form from the Cloudflare cache.

Under cache rules (I searched for this in my cloudflare account) I setup “When incoming requests match” rule to exclude the form submission page. This solved my problem and led to exponentially more contact forms.